AmiQuote Frequently Asked Questions

amiquote
Tags: #<Tag:0x00007fb3dcd309b8>

#1

AmiQuote is pretty much simple program and it JUST WORKS.

If it does not work, it is because either data source you are trying does not provide data or stopped the service, or you have LOCAL problem (installation, connectivity).

Please read the most common questions here covering 99.999% of user problems

  1. AmiQuote stopped working / does not work

    You need to install most recent AmiQuote version (currently 3.27) from
    http://www.amibroker.com/download.html
    any earlier version won't work because Yahoo changed their servers
    (http://www.amibroker.com/kb/2017/05/17/amiquote-yahoo-historical-stopped-working/)

    If you already have AmiQuote 3.27 but it fails to download from say Yahoo, it may be because:

    • You are trying Yahoo CURRENT or Yahoo Fundamental BASIC - Yahoo TERMINATED this service as of November 1. You need to use alternatives: Yahoo HISTORICAL, Yahoo Fundamental EXTRA or Google or Stooq or Tiingo or QuoteDL.com

    • Yahoo (or other web site) started to block your computer/IP because you downloaded too much/too quickly. Web sites implement all kind of abuse protections and will block your IP if you exceed the reasonable limits.

    • You are using outdated operating system not supported by Microsoft (Windows XP or older) - Yahoo now uses newer version of SSL protocol not supported by Windows XP and older.
  2. Why it isn't free anymore?

    AmiQuote was never free. It was always paid program. You were supposed to buy the license if you used it beyond trial.

    Yahoo downloads used to be unlimited in demo but now subject to 10 symbol limit. This is to remind customers that the software is not free. With Yahoo changing their site as often as they do, constant maintenance and upgrades require lots of developer's work and time. And these are not free.

  3. Is AmiQuote license included in AmiBroker Standard / AmiBroker Professional?

    No, AmiQuote license is separate from AmiBroker license. Only if you buy AmiBroker Ultimate Pack you get all three licenses (AmiBroker, AmiQuote and AFL Code Wizard). Trial/demo AmiQuote and AFL code wizard are installed together with AmiBroker installation, but it does not mean that all the licenses are included (unless you buy Ultimate Pack).

  4. Do I have to buy the license to get quotes?

    No, you don't. You can download quotes manually for free. The quotes are available on public sites (Yahoo Finance, Google Finance, Finam, Stooq, Tiingo.com, etc) and can be downloaded with Internet Explorer, Chrome, Firefox and whatever browser you use.

    Also you don't need AmiQuote if you are using other data vendors such as Premium Data, TC2000, IQFeed, eSignal, etc.

    But if you want to download data for more than 10 symbols, enjoying automation and speed provided by AmiQuote that saves countless hours that you would otherwise spend downloading manually from public web sites then you need to purchase the license

  5. I can not install it. I get an "Could not extract the current file. Access denied"

    You are getting this message because some of the files that setup program needs to write are locked by running process.

    You have to close AmiBroker and close AmiQuote, before you run setup program.

    If this does not work, there may be hidden instance running or some other process locking access (antivirus). In such case you need to restart Windows and/or disable antivirus.

  6. There is no data

    Most likely the data are missing on the web site you are accessing or the From-To range that you specified in AmiQuote is incorrect.

    Yahoo or other source that you are accessing may not have the data for that particular symbol (yet). Keep in mind that Yahoo updates its "Historical" source with the delay of many hours.

    AmiQuote is just a web browser, like Firefox, Internet Explorer or Opera, all it does is downloading what is available on Yahoo (or other site). If something is NOT available on Yahoo than no program is able to download something that does not exist.

  7. Data are wrong

    As written above AmiQuote is just a browser that downloads what is available on the web site.

    If you are not getting some data or data are wrong you need to do the following:

  • double click on particular symbol line in AmiQuote after download - it will open downloaded quotes in Notepad and you will see what quotes are really downloaded

  • If there are any missing/invalid you may verify that the same is missing/invalid directly on Yahoo site: https://finance.yahoo.com/quote/^VIX/history?p=^VIX (click on "Download data" link on the page)

  1. Past historical data show all strange red candles

    Yahoo over time changed the format a couple of times. All red candles appear when downloaded close price is lower than day's low. This is may happen if close column is incorrect or when Yahoo changes order of column in downloaded data. In order to get past quotes you need to make sure you keep format up-to-date to be in sync with Yahoo changes. For the most recent change just install AmiQuote 3.27 (or higher) http://www.amibroker.com/download.html.

    To fix existing data you need to change the "FROM" date in AmiQuote to earliest date you are interested in and re-download data for all symbols that are wrong.

  2. Data are not imported into AmiBroker

    If you found that data exist and are downloaded but they are simply not transfered to AmiBroker, it may mean that Automatic Import did not work. It may be because you have unchecked "Automatic import" box in AmiQuote. Make sure it is checked and repeat download

  3. Even if Auto-import is checked the import does not work

    Please verify the following:

  • AmiQuote must have the same bitness as AmiBroker (i.e. 32-bit AmiQuote for 32-bit AmiBroker and 64- bit AQ for 64-bit AB)

  • AmiBroker must be running while AmiQuote is importing

  • both AmiBroker and AmiQuote must be run by same user with same privileges. If you run one "as admin" but the other as normal user - it will not work. Check program icons, they should NOT have "Run as administrator" selected.

  1. I am getting "connection timed out" or other connectivity error or status bar shows that AmiQuote needs to be able to connect

    For example if AmiQuote's status bar looks like this:

    image

    This message means that AmiQuote can not access the internet, most likely because either firewall or antivirus that you are running blocked it. Some antiviruses are pretty bad when comes to interfering with normal operation of Windows and we advise to use Microsoft Defender and/or Security Essentials. You need to complain to your antivirus vendor and tell them they have false positive. We won't do that for you. There are dozens of bad AV vendors and their errors are theirs not ours.

  2. I am getting "local file can't be opened" error

    This error means that AmiQuote is not able to write downloaded data to destination directory on your local hard disk. It may be because:

  • Destination directory is incorrect or does not exist (see Tools->Settings to verify destination folder - it must point to existing folder)

  • Destination directory is NOT writable (it can be marked as 'readonly' or you may not have run proper installation or you may have installed wrong version (both AmiBroker and AmiQuote must have same 'bitness') and/or access to directory is restricted)

  1. What currency pairs are supported by Finam/Forex?

    AmiQuote 3.25 supports 87 pairs by Finam source:

    AUDCAD, AUDCHF, AUDDKK, AUDJPY, AUDNOK, AUDNZD, AUDSEK, AUDSGD, AUDUSD, CADCHF, CADJPY, CADUSD, CHFDKK, CHFJPY, CHFSGD, CHFUSD, DKKUSD, EURAUD, EURBYR, EURCAD, EURCHF, EURCNY, EURGBP, EURHKD, EURHUF, EURJPY, EURKZT, EURLVL, EURMDL, EURNOK, EURNZD, EURRUB, EURSEK, EURSGD, EURTJS, EURUAH, EURUSD, EURUZS, GBPAUD, GBPCAD, GBPCHF, GBPJPY, GBPNOK, GBPSEK, GBPSGD, GBPUSD, HKDUSD, HUFUSD, JPYUSD, MXNUSD, NOKUSD, NZDCAD, NZDJPY, NZDSGD, NZDUSD, PLNUSD, RUBEUR, RUBLVL, RUBUSD, SEKUSD, SGDJPY, SGDUSD, USDBYR, USDCAD, USDCHF, USDCNY, USDDEM, USDDKK, USDHKD, USDHUF, USDIDR, USDINR, USDJPY, USDKZT, USDLVL, USDMDL, USDMXN, USDNOK, USDPLN, USDRUB, USDSEK, USDSGD, USDTJS, USDUAH, USDUZS, USDZAR, ZARUSD

  2. Is Yahoo data adjusted for splits and dividends?

    Yahoo supplies OHLC data adjusted for splits and "adj. close" that is adjusted for splits and dividends. By default AmiQuote 3.25 imports split-adjusted data, but you can choose to get split-and-dividend adjustment data as described in the Knowledge Base: http://www.amibroker.com/kb/2007/08/04/amiquote-and-free-data-from-yahoo/

  3. I got "invalid cookie" error message

    First check if you are running recent AmiQuote (3.25 or higher). Any older version MUST be upgraded.

    Secondly the error may occur if you exceeded Yahoo hourly download limit which is 2000 symbols per hour. If that happens you have to wait one hour and avoid downloading more than 2000 symbols per hour. The easiest method to do so, is to slow down downloads by setting "Initial delay between requests (ms)" to 2000 and "number of simultaneous downloads" to 1. This will implement 1800 symbols per hour rate

    The last reason (unlikely) may be that have invalid cookies in your Internet Explorer browser cache. You need to open INTERNET EXPLORER (NOT any other browser) and go to SETTINGS and CLEAR ALL COOKIES. This is important to use Internet Explorer to clear cookies (even if you use other browsers) as Windows OS and all 3rd party apps (including AmiQuote) use Internet Explorer cookie cache.


Is Amiquote 3.22 downloading Yahoo historical quotes these days?
How to - Cleanup Bad Tickers
Why users don't read FAQ
AmiQuote 3.21 is released now
How to plot Yahoo dividend adjusted OHLC values
Amiquote download issue observed today
Bitcoin/Ethereum/Litecoin
Yahoo message "wait and continue" - never seen before
AmiQuote Volume Data Downloaded from Yahoo Finance Seems Incorrect
Error using Yahoo Current day
Google Finance did not update their page since Sep 5
Google Finance did not update their page since Sep 5
Historical index data
Google Finance data source (EOD) has problem
Wrong historical EOD adjusted prices again from Yahoo
Wrong historical EOD adjusted prices again from Yahoo
#6

#7

Im getting Invalid Cookie error message.

Im using 3.22
Ive cleaned out Explorer Cookies ( deleted them in Settings )

Heres the error message

$NAME AYS.AX
{
“finance”: {
Yahoo Error : code : Unauthorized , description : Invalid cookie
URL: https://query1.finance.yahoo.com/v7/finance/download/AYS.AX?period1=946645200&period2=1502905780&interval=1d&events=history&crumb=C%2FLZLNI0s.G

Constructive suggestions appreciated !

George


#8

One more piece of information. This error seems to happen when I add a new Australian Share symbol and request historical data


#9

This is an error on the data vendor side it would appear that has poped up the last couple of days because amiquote is just a downloader retrieving vendor info.

Anthony


#10

Always check the YAHOO WEB SITE, “Download data” link as shown in this post: Yahoo data errors for ASX symbols

If you clicked on that “Download data” link presented there you will find out that exactly same error is displayed in ANY web browser that you used. It was an error on YAHOO WEB SITE, not in AmiQuote.

But apparently Yahoo fixed their site now.


#11

Yahoo Finance again changed their service. Now they implemented 2000 symbols per hour maximum download limit.

So if you are getting now ‘invalid cookie’ error it may mean that you exceeded Yahoo hourly download limit which is 2000 symbols per hour. If that happens you have to wait one hour and avoid downloading more than 2000 symbols per hour.


#12

The easiest method to slow down downloads to “safe” rate of 1800 symbols per second is to go to AmiQuote Settings (Tools->Settings) and set:

  • Initial delay between requests (ms) to 2000
  • Number of simultaneous downloads to 1

image


Before posting please read this
#13

Hi All:

I am getting a strange error with Amiquote when updating the Tickers. It’s only happening to one of my databases, the others seem to be fine. Not sure what is causing the problem. I added a ticker symbol that was not an actual ticker symbol on yahoo (inserted wrong symbol). That is when it started, since then I deleted the ticker but I am still getting the error.

Any solution would be appreciated.

TIA

Amiquote


#14

You answered your own question already - your database is causing the problem.
I have never seen such error message and it does NOT come from AmiQuote. It comes from Windows OS. To fix, REMOVE the source of the problem - i.e your database. And create new.


#15

I’m not too sure about that. Anyways, I didn’t change anything with the database and just changed the date range (from - to) and it stopped. Not sure how that would be a windows OS problem but I am not a programmer. Problem solved somehow !!

Cheers


#16

If you were careful reader you would notice that I did not say that it is Windows OS problem but that the message “comes from Windows OS”. Programmers are precise. Non-programmers are not. What I wrote is not the same what you 'interpreted". Why do I know that it does not come from AmiQuote? Because for the message to come from the program that I have written myself, I would need to write “unspecified error” text MYSELF in the program code. And I didn’t. There is no such message in program code. I don’t write nonsensical messages in my source files. So this “clever” message is generated by Windows. If you googled for “unspecified error” you would find out that it may be file system error or internet error or any other error coming from the OS.


#17

Thank you for the clarification. I’ll make sure to read more carefully in the future.


#18

Hello,

I tried to download ^DJI with Amiquote 3.25 on Stooq source but I get the message “No Data for this symbol”.
Can anyone suggest a data source for US indexes (using Amiquote supported sources)?

Regards
Richard


#19

image


#20

Hello Tomasz,

It is very strange. I tried multiple times with or without translation table. In general Amiquote works fine for all sources.
I have done a few more tests and I can get $DJI from Quandl.com
I can get any other symbol from Stooq (like C.US or ^SPX) - just not the ^DJI, ^DJT or ^DJU
Will date format matter or any of my Win10 settings? I will try on my laptop and see if works there.

image

Thank you for your assistance.

Kind Regards
Richard


#21

Hello Tomasz,

I just tried the same symbol ^DJI on my Win10 Laptop and it worked fine.
My desktop PC still refuses to work.

Kind Regards
Richard


#22

No it is not strange.

No surprise it does not work when you have incorrect entries in translation table.

As things stand now you are translating ^DJI( correct symbol for Stooq ) into $DJI (incorrect!!!)

Remove ALL items from Translation table for Stooq - they are incorrect.


#23

Hello Tomasz,

Thank you for your answer. It was my (user) error. I had my translation table in reverse.
It was my misinterpretation of what source and what destination is.
With my database symbol $DJI translated to ^DJI (Stooq symbol) it all works fine.

Kind Regards
Richard


#24

Richard it is very nice of you and very decent that you said that. Thank you.