AmiQuote Frequently Asked Questions

Tags: #<Tag:0x00007f80490c0eb0>


Just an FYI. I created a new database and added 2 new symbols to it. I am receiving the “unspecified error” dialog box on this database/symbols. Haven’t been able to rectify it by changing the from-to range like last time.



edit post:

was happening on (.TO) symbols which I thought was isolated issue. Tried a new database with US stocks and happening as well. Still can’t get around it for some reason. All existing databases are OK. Any help is appreciated as I cannot create a new database and download historical data.


As I wrote: “unspecified error” says nothing. There is no such message in AmiQuote’s source (program). So it comes from Windows, not AmiQuote (“comes from” does not mean “is displayed by”, “comes from” means “the source of it is”, so the source of the error is OS). It may be Windows OLE error. It may be because you have some strange config of Windows. I can only guess that you must be using something that no-body else does, because no-body else but you are having problem. It would help if you actually described exactly what you do and when exactly the error pops up. Otherwise we are playing guessing games.
Do you type the date or do you PICK it from the date time picker? It is advised to use the picker instead of typing.



I understand this a “windows OS” message box. The only time I get this message box is when using Amiquote with yahoo historical data download option. I have a plain vanilla install of Windows nothing ‘strange’ going on.

Current steps to reproduce the error:
i) Open Amibroker
ii) Create new database
iii) select ‘Symbol’ tab --> 'new’
iv) Add ‘TD’ in ‘new symbol’ dialog box
v) Select ‘Tools’ tab --> 'Auto-update quotes (AmiQuote)'
vi) Default settings and ‘From-To’ Range - Amiquote automatically begins data download attempt
vii) I see ‘setting up yahoo finance connection (quick) …’ on symbol. The moment it switches to message ‘Initiating download…’ THIS IS WHEN UNSPECIFIED ERROR DIALOG BOX APPEARS

If there is anything else you need please advise.



OK, it seems that I have found the reason of the problem you are having. Interestingly it occurs only in 64 bit version. 32-bit version works perfectly fine.

64-bit version would display this message if and only if you have completely blank database (no symbols at all) or you have just symbol without any quotes. The workaround is simple. Start AmiQuote standalone, and add just one symbol in AmiQuote ("+" button). Then initiate download and it will work just fine. This is only required once (when you have blank database). Once database has any data in it, you don’t need to do that anymore.

I also implemented a fix so 3.26 won’t display such message at all.


The ‘workaround’ works. Thank you very much !!

other souce beside Yahoo for Indonesian stock such as: ^JKSE , etc


Could anyone help me where I can get other source for download historical and daily ticker fo ^JKSE and other indonesian Stocks beside Yahoo is now terminated?

many thanks


Yahoo HISTORICAL works fine
So instead of “CURRENT” just use HISTORICAL.


Hi, I’ve checked all the sections of AmiQuote doesn’t work, but it still doesn’t work. Nothing downloads. I have only 30 days to try it out and be sure I need to spend the money. What can I do now?


Sorry, but I think what you say is rather rude. Do you seriously think that hundreds of people using it everyday without problem are all wrong? And that we released thing that does not work at all? If it did not work we would not sell any. But it sells quite nicely and people thank us everyday for making it available. Also FYI: unlike products of big corporations this product is unique. I written it for my OWN use and I USE IT MYSELF everyday. So I know it works. Free trial allows you to check everything risk free. You tried and it did not work on your computer. With tons of other harmful softwares that people get installed on their computers it may happen. Sorry, but it may be just not for you, as it works perfectly fine for everybody else.



AmiQuote works very well!

But maybe you did not set properly the list of symbols to import.

I just created a new empty database, scraped a list of 538 tickers/symbols from the official Jakarta exchange site, put them in a .tls file, launched Amiquote, loaded that list and using Yahoo historical I filled my database from January 2010 until now in few minutes (EOD).


534 tickers imported / 4 failed (this means that for these few tickers Yahoo does not provide the historical series).

The list should be like this:

....... etc. ......

For many symbols, the imported data seems questionable, but I do not know anything about the Indonesian market to be sure about that.
In any case, the most commonly traded symbols charts seem OK to me.


Maybe you should review the documentation and try again!

P.S. While AmiQuote is running, AmiBroker too (with the selected database) should be open for the Automatic Import to work.


Thank you very much Giuseppe for posting such detailed usage example.


Hi Tomasz,

Can you please advise regarding a decent source of Australian ASX data?

I have been using Yahoo Historical ever since the Current was no longer available. However, I have found that the current days data is correct if I download late in the business day. If I download early in the day I get data but dated the previous day.

The real problem occurs when I have been away for a few days and attempt to download really historical data (a week or two at a time). Yahoo provides accurate data but it is dated the day before it occurred. I have confirmed this using the Download Data link on their webpage. For example the 1 Dec 2017 data is shown as 30 Nov 2017. This is NOT a show stopper but I would like to access more solid data. Yahoo is crumbling around me.

Many thanks


Yahoo seems to use US time zone and that is why early in the day (in Australia) you are getting previous day date (in US it is still “previous day”).

The most decent (curated) source of ASX data is Premium Data. It is is paid source but many customers choose that for convenience and hassle-free operation.


Thanks Tomasz,

You have explained the early morning issue but do you have any idea about the real historic data? This “day early” dating for aged data cannot be simply time zone issues.




It is timezone issue because for two weeks in a year USA and Australia have mismatch of daylight saving: Yahoo data errors for ASX symbols



I can not download historical data from ...

I try to download data from yahoo, and got small window, saying :

You have reached yahoo dowload limit of 2000 symbols per hour ... ...

I did not download data today ?!

Any ideas ?



You or somebody else downloaded too much / too fast using your IP address, see: AmiQuote Frequently Asked Questions

Wait and retry after few hours.