DUPLICATE QuickAFL in Analysis window, was: Amibroker date range


#1

The problem is when I select date range from “From to date” to see buy and sell in my scan window ,it shows wrong result because it first calculate all the dates present in data like :ALL Quotes" and then show result of that particular dates.

What i can do in amibroker so that it actually start calculating data from the selected range rather than all quotes.???


#2

Assumptions are not facts. Your assumptions are wrong. You did not read the docs and did not search the forum prior to posting.

It is NOT wrong to use all quotes for calculations because majority of functions require at least few quotes BEFORE your first date (such as simple moving averages) to produce any result. Some functions in theory may require ALL bars (all kind of recursive functions).
So if you tried only to use quotes in your range you will get huge “NULL” sector at the beginning.

You may however limit the number of bars used if you turn on Quick AFL, but again, you did not read the docs that were mentioned zillions of times already:
http://www.amibroker.com/kb/2008/07/03/quickafl/

and you did not search the forum that already has that subject:


#3

The topic is duplicate of:


#4