eSignal dropped support for 32-bit apps - use 64-bit AmiBroker if you use eSignal


Sometime ago eSignal stopped delivering 32-bit version of eSignal application. This had (almost) no effect on existing apps until recently. Starting from November they silently changed the way they deliver quotes and this new method only works with new DBCAPI.DLL versions.

They come as 64-bit only and for this reason starting from November 2017 you have to use 64-bit version of AmiBroker to access eSignal data.

Minimum requirement to access eSignal data now is:

AmiBroker 6.00 64-bit or later