Import tick data with millisecond from ninjatrader8


Goodmorning everyone,
please i export FESX data ninjatrder8 in tick format like this with bid ask and millisecond data …
20171023; 060006 0540000;3603;3603;3603;281
20171023; 060006 0540000;3603;3602;3603;1
20171023; 060006 0660000;3602;3602;3603;15

when imported in to AB it’s converted in day quote , so i have tried with this format too but nothing
20171023; 060006,0540000;3603;3603;3603;281
20171023; 060006, 0540000;3603;3602;3603;1
20171023; 060006, 0660000;3602;3602;3603;15

how i can do f?


You need the following TIME format:


where mmm is milliseconds and uuu is microseconds.

So you need a DOT, not comma in your timestamp

20171023; 060006.054000;3603;3603;3603;281

And of course you need to use recent version of AmiBroker (6.14 or higher) to get support for microsecond timestamps in ASCII importer


just tried but nothing…it’s import in EOD format…
i have write in format mode $tickmode 1 also…


Which is your Base time interval of your database ? (File->Database Settings)


tick time frase setting on database…


So is is TICK data or is it EOD ?? Could you make up your mind? In the subject you tell that you get tick data then out of the blue you tell that you are EOD format. For EOD why then you need those milliseconds??? You don’t need them for EOD. EOD bar is one per day - so there is NO time component. Use SKIP for that field. And NO, $TICKMODE is NOT for end-of-day data.


these are tickdata that i’d like to import in AB,
with this format AB convert in EOD .
database setting is tick

yyyymmdd time last aux1 aux2 Vol
20171023; 060006,0540000;3603;3603;3603;281
20171023; 060006, 0550000;3603;3602;3603;1
20171023; 060006, 0660000;3602;3602;3603;1