Intraday database issue


I exported the SP500 constituents 60min data to csv files from TradeStation in this format:
Date (YMD), Time, Open, High, Low, Close, Last, Volume

I created a new database in Amibroker, setup a custom ASCII format, and imported the data successfully, and I can use it in charts. The issue is that I cannot get the bars to include data all the way through the whole day. I edited the intraday settings to use day session only, set the session times, set the time shift, but my charts always cut off the last 1.5 hours of the day. What am I doing wrong?


Sorry I cant help you but I had some problems doing the opposite
I have been trying to export data to Tradestation format for some
app that needs Tradestation format.
Tradestation is timestamped at the end of the bar. Amibroker
is timestamped at the beginning of a bar.
You can set Amibroker to use endstamps but I found that
for example when using 1 hourly data the close time of the exported
data was 16:30 instead of 16:00. The start time was changed to 10:30
instead of 9:30 in this case so it was not as easy as shifting time.
I did have correct quotes and starting/end times when using timestamps
at beginning when exporting. So appearantly only using the standard Amibroker
setting worked but it could be an error on my side or the afl that I used.
My database base time interval in Amibroker was 5 min.


Go to Tools->Preferences, "Intraday" tab and NOTE that by default there is a checkbox "align minute bars to regular market hours" turned ON. So if your session starts 9:30 the hourly bar will be aligned to 9:30 as per settings, so they will start at 9:30.
Turn this OFF, if you want 9:00, 10:00 bars.


Thanks I will try
What a good support so late in the saterday night !


getting closer......

I am using hourly bars (60min.) In TS, these look like:
9:30am, 10:30am, 11:30am, 12:30pm, 1:30pm, 2:30pm, 3:30pm, 4:00pm

But in Ami, now my bars look like:
10:00am, 11:00am, 12:00pm, 1:00pm, 2:00pm, 3:00pm, 4:00pm

Notice in TS how the last bar is not on the half hour, but ends on the whole hour. How can I mimic this exact pattern Ami?


Here is a snapshot of the data format that I am trying to use. I built a TS app to export this data as a CSV in this format:
Symbol, YYYYMMDD, Time, Open, High, Low, Close, Volume


You can see that the bars are in central standard time, and the time stamp is for end-of-bar. So, 9:30am is the first bar of the day, and 3:00pm is the last bar of the day.

I've got all of the bars lining up except the last two bars of the day. No matter how I set the settings in the intraday section of the DB setup and the intraday setup in preferences, I cannot get these last two bars to come out correctly on my Ami charts. Are there any other intraday settings that I do not know about?

Here are snapshots of the last couple of bars, side-by-side with Tradestation. You can see the 1:30pm bars DO line up. But when I get to the 2:30pm bar, in Ami, it calls that the 3:00pm bar (and no others follow for the day), and completely skips over the 2:30pm bar. It seems to merge the 2:30pm bar with the 3:00pm bar into one bar (incorrect.)

Correct 1:30pm bar:

Incorrect 2:30pm bar:

Here are snapshots of the two places I have been messing with settings to no avail:
DB's intraday settings:

Tools-preferences-intraday settings:

Can someone please tell me why I cannot get the last two bars to line up????

I am trying to mimic the time sequence in the first snapshot I sent above. IE:
9:30am, 10:30am, 11:30am, 12:30pm, 1:30pm, 2:30pm, 3:00pm (last bar of day)


As the CSV snapshot shows, there should be 7 bars in the day, but on the Ami chart, there are only 6 bars.


Could you post the snapshot of day 02/01/2018 using Symbol->Quote Editor ?




Didi you try "Show 24 hours trading (no filtering)" option in window "Intraday settings" ?


yes, but when I do that, the first bar of day becomes 10:29:59am (instead of 9:30:00am like it used to), and the last bar of day is now 3:29:59pm (instead of what it should be: 3:00:00pm) Still only six bars in the day instead of seven too.


I see, one more test.
select "Show day session only again"
but change Day Session End to 15:30



I did. No dice. And I've tried, what seems every which way here and I cannot get it. Ugggghhhh

Still only shows six bars in the day too, instead of seven.


Read this


One last try, but backup your database first.
Keep the last sugested configuration, but change your "base time interval" from Hourly to minute in Database settings


awilson, that did not work. codejunkie, I have read that article and the one underneath too and nothing is working. It keeps combining the last two bars into a single bar.


Amibroker output is correct!
15:00 belongs to hour 14:30 to 15:29:59 so it merge it with your 14:30 data showing only 6 hourly candle.


The issue with this is that I run automation in Tradestation, and I am using Amibroker to do rapid portfolio level backtesting. I have indicators, IE: Moving Averages, that are in my strategies. So with a different amount of bars, the MA's will never compute the same unless the number of bars, and the data is the same between the two platforms.


The only way I see is during exportation or before importing to Amibroker you change 15:00:00 to 15:30:00


now there's a good idea. Let me try.