Latest IB Plugin for 64bit

backtest
howto
Tags: #<Tag:0x00007f2d7b573ed8> #<Tag:0x00007f2d7b573d98>

#1

Unable to find latest IB plugin for 64bit version release 6.27.1

I am having trouble getting back-fill data on long symbols


#2

The latest plugin for IB as well as all the other sources are included in the setup program and already installed inside "Plugins" subfolder. There is nothing extra to install at the moment.

Any new version will be released along with AmiBroker updates, not separately.


#3

The platform is useless to me without this fix giving me the ability to back-test long symbol names.


#4

If I wrote something like that to the user it would be considered as rude.

Maybe if you could at least tell exact symbol you've got problem with someone would be able to help.

Backfill of long symbol WORKS equally well as short symbols. Maybe you just using wrong symbol but we don't know that since you don't tell the symbol.


#5

I've been hearing about this fix for quite some time through a developer that I have been working with. I will get with him and ask if it is working or if the problem still exists.

I wasn't trying to be rude at all but rather just trying to get some traction on this.

I am unable to see how to copy the symbol from the platform but here is one that I am unable to get data on.

A symbol that I might like to get data on is this one


#6

This particular symbol is EXPIRED (expire date January 12) and IB API does not offer data for expired symbols.

You need to use CORRECT and ACTIVE symbol.

Correct symbol for NON-expired option is for example

AAPL  180216C00170000-SMART-OPT

and it backfills perfectly fine:

image

and video WHILE it is backfilling:

6609ba7d-6267-4037-805b-2c5821254b5d


#7

[quote="Tomasz, post:6, topic:4268"]
AAPL 180216C00170000-SMART-OPT
[/quote]Sounds good. I can't wait to give it a try. Thank you for informing me that this has been here all along.


#8

This is what I get when testing this with "backfill current"


#9

You do NOT need to click "backfill current" AT ALL. Backfills are AUTOMATIC turned on by default and don't require any clicking. As described in manual:
http://www.amibroker.com/ib.html

Quote:
IB Backfill feature is configurable from File->Database Settings, Configure :

image

You might have switched them OFF yourself and the fix you need is use the DEFAULT, i.e. turn it back on.


#12

I must have had something wrong in the symbol name. Must have been a space or something. The backfill current isn't working but the automatic one DOES seem to be working!