Amibroker 4.40.4 Error message during optimization and walkforward

Hello !
I am testing QTS Howard Bandy's sector rotation Figure 15.1.
Untill now optimization and walk-forward worked flawlessly.
But suddenly i get the error message :
"**Notice You havent specified any variables for optimization" **
and the "Details...: button doen't respond.
This error message with calamitous results appears even on formula versions
which walked-forward fairly well yesterday and previously. !
I restarted Amibroker and the computer and still i get the same error message.
Any suggestion and elements to check ?

I suggest you add in the next Amibroker version a "Miracle" button. (joke).
Traveler

You need to read the Users guide
https://www.amibroker.com/guide/h_optimization.html

Also minimum supported version on this forum is version 6.0

Hello Tomasz,
Thk you for yr advice.
You wrote :
"Generally, in case of problems with formula that worked before
the reason is usually elsewhere.
Check if you did not use "custom backtest formula".
Probably you have defined formula that is incorrect.
Disable custom backtest and retry.."

Neither the custom backtest procedure was enabled nor coded thru "SetOption("UseCustomBacktestProc".
Bandy formulas and my variations are correct since they are sent successfully to Analysis windows and walk forward procedure goes on correctly.
I retried and the error message still pops-up !
Any other suggestion to test ?

Hereunder screen copies displaying the error message.

Regards to Marcin as well.
Traveler

Capture d’écran 2022-08-12 120843 Backtester procedure disabled

Here attached screen copies of the error message got from Bandy's formulas. My formula library is stored in Formulas / Custom 2017

Capture d’écran 2022-08-12 121328 Custom formula library is located in Custom 2017 file

Capture d’écran 2022-08-12 120255 Error message 1
Capture d’écran 2022-08-12 120344 Error message 2

image
image

You can post dozens of repeated pictures but they are not helpful, since they just show the same thing over and over again.
I don't care if you took formula from Bandy's book or somebody's else.

You should use OFFICIAL USERS GUIDE. That is first and final reference.

You should just write CORRECT FORMULA as instructed How to optimize trading system

Take first example

sigavg = Optimize( "Signal average", 9, 2, 20, 1 );

Buy = Cross( MACD( 12, 26 ), Signal( 12, 26, sigavg ) );
Sell = Cross( Signal( 12, 26, sigavg ), MACD( 12, 26 ) );
  1. Copy-paste to Formula Editor,
  2. then click "Send to Analysis" button in the formula editor
  3. then click Optimize in Analysis

Also: check other pages in the Settings, turn off PADDING, select "All symbols" and "all quotations".

1 Like

hello Tomasz,
Optimize in analysis window yr recommended example :
Result effective and fine.
Padding is now "off".
"All symbols"and "All quotes" are selected.
Walkforward with this very same example gives again the same error message.
Traveler

Use walkforward in EASY mode and make sure that dates selected exist in the database

https://www.amibroker.com/guide/h_walkforward.html

Also note that AmiBroker 4.40 that you are referring to in the subject line does not have walkforward testing. Walk forward was introduced in version 5.10

The error message has disappeared !
Optimized walkforward systems
from now on work again flawlessly.
The issue came from walkforward advance mode, i used it to help me to change the Start, End, Last and step parameters. I had a small mistake and i did not ended by switching to EASY Mode. From now on, i shall stick to.
Thank you for yr help.
Good night
The Traveler
PS
My Amibroker version is 6.40.4 renewed Feb 2 2022. You may check, if need be, in your records.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.