AmiQuote not working with yahoo EOD today (probably for some in Asia only)

Hi,

AmiQuote seems stop working today suddenly with Yahoo EOD data source. Any idea why?

Ken

1 Like

I'm also having the same problem. Tried on 2 seperate computers and no luck

Working for me at 9:00 est.

1 Like

Now I can barely can download a few. AmiQuote seems almost immediately give me the error "Download limit reached" . Anything I can do? I have tried several setup options but nothing works.
360%E6%88%AA%E5%9B%BE18141219245965

1 Like

Really, are you not able to unterstand the clear text of the dialog? AFAICS it clearly tells you that you have reached download limit set by data vendor. So data source is blocking you... so you simply have to wait as told to you.

The wait time is set on purpose in AQ default settings. Better don't change default ones. They are there for a reason.

7

Try to reduce number of simultaneous downloads (set fail save defaults).
8

You have abused free download service of data vendor. So you have to wait for next free ride. There are limits of free ride. Do you understand meaning of waiting? It requires time to elapse. So please be passioned and drink some coffee and eat some cake. And then come back in few minutes and try downloading less and stay within limits next time.

Amiquote is just a web browser and AmiBroker not being a data vendor as been told many times on this forum by the developer. If you have problems with download limits then complain to data vendor or get a commercial one instead of free one... But don't be surprised then because commercial ones do have limits too.

You're welcome.

1 Like

It was temporarily not working over the last few days and when it came back up there were small download limits.

It appears to be back to normal now I just downloaded updates for US market EOD 1800 symbols without any limiting

This is great to hear! Thank you very much Homer!

My setting has been working the way it is for more than a year. As I have said, I tried to tune down the settings and none corrects the problem. I just tried with your suggested setting and it DOES NOT WORK!

I am not accusing I am just telling you what AQ is telling you by pop up message in great detail.
The message does not show up without reason! You have simply reached Yahoo limit. There isn't anyhing difficult about it.

I have even given you advise on how to prevent it by setting fail safe mode in AQ settings. No good deed goes unpunished.

Just because it has worked before does not mean that data vendor will not block your IP in future.
In similar fashion... Just because someone drives too fast and everything has gone well in the past does not mean he/she won't crash a tree in future.

2 Likes

Just tried and it works perfectly fine as of today September 6, 2019, 09:00 UTC, see this:

test

So @fxshrat was right all the way. If you are/were experiencing problem it is/was because of either:

  • downloading too much too quickly and Yahoo treated you like kind of attacker (Denial of Service attack) and blocked you (your IP), or
  • there was some temporary Yahoo problem (but now it works)

If Yahoo blocked you, you can only wait until they unblock you (or connect from different IP and clear cookies)

There is a possibility that Yahoo lowered the hourly download limits and people who were not hitting the limits before now are hitting them. Previous limit was about 2000 downloads per hour. If you are hitting the limit, connect with different IP and try not to download too much.

2 Likes

Thanks Tomasz! That is great to hear. On my end, there seems still a problem. Since I am in Asia and their web server could be a distributed one, it may take a while to push their new fix to the server that I am connecting too. I will wait for a day or two to see if the problem goes away.

Thanks again!
Ken

And I did clear cookies and connect via different IP (my mobile), the problem persists. So does not look like a blocking IP issue. Will just wait for a day or two.

I encountered IP block last month using my script download from Yahoo Finance. I used the free ProtonVPN and it fixed the problem. It has since been unblocked. Alternatively, you can download EOD from eoddata.com but you have to register first. It's free to daily data. It comes in one file for NASDAQ and one for NYSE. It's a package deal and you need to figure out how to remove those tickers that you don't want.

Here is latest test. I downloaded one year worth of data for 6608 symbols in a matter of 5 minutes (video below is speeded up 100x). I used 10 simultaneous downloads. No problems at all. And I did not hit any limit.

test

1 Like

I believe it's a regional issue.

No official changes declared yet, still the same:

image
(Source: https://developer.yahoo.com/yql/guide/overview.html)

The title of this thread is misleading.

Thanks for the pointer, I will try out eoddata.com!

Ken

I tried again this morning (Asia). The problem still exists. I start to believe, as you said, could be a regional problem.

Ken

I tried again this morning but it seems the problem still exist. My download is very moderate. Only 70 tickers and only 1 download thread with 2 weeks worth of data. It went for about 30 tickers successfully. Then it stops with an error. If I cancel out from the wait dialog box and start download again from where it lefts off, it will go further. I screenshot the error below. The error shows it is some kind of invalid cookie error. I am not sure what it means? Any pointer or explanation is appreciated.

360%E6%88%AA%E5%9B%BE17001011105101102

I encountered the same issue today 7Sep2019 Asian morning.

I have been downloading end-of-day quotes using Yahoo Finance with AmiQuote for global indices for many years. I encountered a message box "reached download limit. Wait and Continue" after downloading only a few symbols quotes. This is unusual because the download limit is extremely low. I hit it after downloading like, say less than 20 bars, of data.

Luckily, I was able to download later. I suspect this has something to do with Yahoo Finance server overload. I'm confident this problem is not related to AmiQuote.

I changed the setting of waiting to redownload from 10 minutes to 1 minute so that I don't have to wait so long if the problem happens again.

1 Like

Thanks for the info! It is good to know I am not alone and this coud very well be a regional issue. I guess I may just have to wait until the problem goes away and I hope it will. For now, I can always cancel out from the wait dialog and continue again, or just let it wait. I did change the wait time to 1 min also.