AmiQuote not working with yahoo EOD today (probably for some in Asia only)

I believe it's a regional issue.

No official changes declared yet, still the same:

image
(Source: https://developer.yahoo.com/yql/guide/overview.html)

The title of this thread is misleading.

Thanks for the pointer, I will try out eoddata.com!

Ken

I tried again this morning (Asia). The problem still exists. I start to believe, as you said, could be a regional problem.

Ken

I tried again this morning but it seems the problem still exist. My download is very moderate. Only 70 tickers and only 1 download thread with 2 weeks worth of data. It went for about 30 tickers successfully. Then it stops with an error. If I cancel out from the wait dialog box and start download again from where it lefts off, it will go further. I screenshot the error below. The error shows it is some kind of invalid cookie error. I am not sure what it means? Any pointer or explanation is appreciated.

360%E6%88%AA%E5%9B%BE17001011105101102

I encountered the same issue today 7Sep2019 Asian morning.

I have been downloading end-of-day quotes using Yahoo Finance with AmiQuote for global indices for many years. I encountered a message box "reached download limit. Wait and Continue" after downloading only a few symbols quotes. This is unusual because the download limit is extremely low. I hit it after downloading like, say less than 20 bars, of data.

Luckily, I was able to download later. I suspect this has something to do with Yahoo Finance server overload. I'm confident this problem is not related to AmiQuote.

I changed the setting of waiting to redownload from 10 minutes to 1 minute so that I don't have to wait so long if the problem happens again.

1 Like

Thanks for the info! It is good to know I am not alone and this coud very well be a regional issue. I guess I may just have to wait until the problem goes away and I hope it will. For now, I can always cancel out from the wait dialog and continue again, or just let it wait. I did change the wait time to 1 min also.

I encounter the same problem to day. i did downloading from china and experience the datalimit problem.
The problem seems gone after i connect via vpn with server in UK.
Clearly a regional issue. I hope its technical rather than political treatment.

1 Like

Thanks for the info! Great to know... I am in HK by the way. So the problem could be asia-wide not just China.

@kzliao - please send actual file (.aqh) with the full error text to support (by email) because the screenshot is truncated and relevant information is cut off.

Also you need to know that "Wait and Continue" dialog is designed so it waits and CONTINUES the download without manual intervention. You don't need to cancel, you just need to leave it and it will wait, clear cookie and reconnect automatically. This was specifically designed and programmed to automatically resolve "invalid cookie" error.
If you cancel this dialog and restart manually you are making things worse. The timeout period is designed to SLOW DOWN requests so you don't hit Yahoo limits.

@Tomasz - OK, I will send the error message via email to support.

As user etcjkam suggested, I signed up for a VPN service and connected to an UK VPN server, now my download works well as before. This confirms the problem is regional.

Thanks for everyone's help and suggestion!
Ken

Yahoo servers have been facing problems globally since this week.
Use search engines...
It is not just Yahoo mail but several other services of Yahoo.
https://www.google.com/search?q=yahoo+server+problem&sxsrf=ACYBGNT79SapfnJ2qhB0dYwXGvCG5EjRHw:1567843532003&source=lnms&tbm=nws&sa=X&ved=0ahUKEwichKemoL7kAhXE2qQKHUcqCtsQ_AUIEigB&biw=1637&bih=852

Yahoo tweet: "You may not be able to access some of our services, including email. Our top priority right now is getting this fixed. We appreciate your patience."

7

If you face problems with (data) vendor then you need to go to vendors themselves (first) to check for issues.

2 Likes

Ha, good to know. Thanks for the info...

Ken

Hi kzliao,
I'm from Indonesia and having same problem since last week.
Limit data, awaiting for 10 minutes then start again counting from zero

Rgds

Jhon

Hi fxshrat,

I think this is correct.
Currently I'm using Amiquote registered one.
then connect using VPN Singapore and the problem of limited still exist.
I change the country to UK then the problem solved.

Thx to etcjkam

Jhon

As of today (2019-09-09) morning, the problem with Yahoo Asia server seems fixed. I am able to download smoothly without vpn.

Ken

1 Like

I like to report that this is still happening as of 22 Oct. I have one database with only 88 symbols where it was happening. It doesn't happen all the time.

Also if I cancel the wait box and press run again it continues with the remaining ones without any delay. This would seem to suggest that whatever message Yahoo is sending amiquote doesn't actually NEED to stop.

Also it seems that if you specify a specific date range the message doesn't seem to trigger. Only one test but on a DB with 4000 symbols I went back two months

I notice the mention of asia servers above. I am in Oz so perhaps I am accessing those also. All of these DBs have been in use for some time and were working fine. So something has changed on Yahoo's side.

Same thing happened to my. I am in north america. I can continue download after I cancel the dialog and let it run again immediately.

No it does NOT mean that. Yahoo blocked you because you downloaded too much too fast. You are supposed to wait until dialog auto-continues by itself. If you cancel prematurely without waiting you are risking getting under Yahoo radar and blocking you permanently.

Cancelling prematurely works because it is designed to work. It clears all cookies but that would work only few times. If you fall under Yahoo radar they will block your IP.

If you are getting this dialog LET IT count down to zero and auto-continue. That way is safe. Cancelling prematurely all the time is NOT.

Thanks for the clarification Tomasz. However it leaves outstanding the question of what is happening with Yahoo. I am by no means a large down loader of data from Yahoo and recently its even more minimal than usual.

You mention that Yahoo could permanently block my IP. That would be difficult as the address I have is assigned by CG-NAT. Perhaps that's the problem they are aggregating all the requests the come from users behind the same CGNAT address