AmiQuote "Server Busy"

Since I was missing too many new tickers at Tiingo, I decided to uncomment the below lines from my daily JS file:

AQ.RemoveAllSymbols()
AQ.AddSymbols( "_ALLSYMBOLS_")
AQ.AutoImport = true// import automatically
AQ.Source = 2; // Tiingo Current EOD
AQ.Download(); // starts download
while( AQ.DownloadInProgress || AQ.ImportInProgress )
{
WScript.sleep(5000); // wait 5 seconds before querying status again
}

However, during and after import AmiQuote results in a "Server Busy" error which halts or messes up further script execution (which I vaguely recall is among the original reasons why I commented those lines out):

image

So the question is, what is at fault here and how to resolve? JS? OLE? AmiQuote? AmiBroker? And how to fix it? This is a 40-core machine running Windows 10. Non-responding application time out needs to be increased? Other possibilities?

So the problem is clearly with AmiQuote timing out waiting for AmiBroker.

I was able to download the same ~15,000 ticker symbols in R and import without any issues. Not as convenient, but it will do.

This message can be triggered by Windows OLE if it takes more than 5 seconds to import given file. It is not an error. it is just a message that you could ignore (click "switch to" and wait). Imports of 14000 symbols may be slowed down by disk access. You can only speed up imports if you increase in-memory cache in AmiBroker (in Tools->Preferences, "Data")

Increasing the memory certainly solves the slow import problem and prevents the dialog, but ran into an edge case where the previous command in the script aborted on some kind of an error and the subsequent import of the tickers acted as if the memory limitation was back to the original small size, so the timeout window popped up again. Since this is all automated in the background, clicking "switch to" to allow further script execution isn't really an option.

Regardless, there is such a massive amount of junk in Tiingo's zip file, it is absolutely pointless to bother with. There's simply no way to filter out all of the Operating Companies.