Avoid IQFeed backfill

The problem is that diring the backfill if completely deletes small lots (<100 shares) and replaces it with regular ones >=100 shares. And sometimes candles become 1 trade at 1 price.
Is it possible to let it only real time feed?

I very much doubt the IQFeed plugin deletes anything. Sounds like you have enabled the 'Consolidate trades with same TickID'. Which means that in a Tick DB, it will show you Volume per order instead of splitting it up.

File => Database Settings => Configure.


If that's not it- then you have to give the AB Community way more information for solving your problem- AB version, Instrument, base interval, screen captures etc.


That is true that IQFeed does NOT include odd-lot trades (<100 shares) in backfill, at least in time-based bars.

And it is also true that those odd-lot trades are present in real time stream and they are included in bars build from real-time data by the plugin.

For some reason IQFeed believes that odd-lot trades are unimportant and they decide NOT to include them in backfill, yet they are present in real time stream.

They are well aware of that as it was their "business decision" to do so but I don't know their motivation.

1 Like

I cannot check that as I dont have that option in my 6.18 Amibroker. Can you check that please with any low tradable ticket like CMPR, EBON, etc.?

For the moment I found the only decision which is very stupid but working-I collect real time data from IQFeed with one instance of Amibroker (32bit) saving them to txt file to RAM disk and trade with the other Amibroker (64bit) importing that file as indicator script.