Backtester periodicity issue

Need help to change periodicity to 1 min / 5 min / 15 min, etc. I was able to this in a trail version 6.0 earlier. Now, I am using 6.20.1.

Tried a lot to find settings, but I am unable to find. Requesting help after 2 days.

Thanks!

image

1 Like

@ssekhar2608 I have never seen that before. But maybe, have you tried adjusting your "preferences" on the Intraday tab,

image

@portfoliobuilder,

Thanks for your response!

I started seeing this issue right after I installed 6.20.1
Later I have changed Intraday settings though. However, Intraday settings would not affect Backtester periodicity, right?

Some general Information about database and intervals (for your case see last two paragraphs):

Once you have created an AmiBroker database then you surely have set a Base Time Interval in Database Settings (File - Database settings). That one is the overall interval that determines which subsequent intervals are possible to set within AmiBroker.

2018-06-02_165656

Suppose you have set "Base Time Interval" to "Hourly". Then interval buttons of AmiBroker tool bar being shorter intervals than that one will be shown greyed out (e.g. 1-minute to 15-minute). In newer versions (AmiBroker 5.60++) the implemented chart interval selector box (see 2nd picture below) still allows to set shorter intervals than set base time interval (so for example if you have imported data being of a shorter interval than set base time interval of File - Database settings then in charts you still can set intervals being shorter than that base time interval. But if that set interval of chart interval combo box does not exist in the form of imported data then the actual interval of the imported data will be shown no matter what shorter-than-base-time-interval or shorter-than-data-interval you have set there, unsurprisingly. So in latter case don't get confused if AB shows set 1-minute on chart title despite of actual interval of imported data being EOD).

This one is the Interval combo box (for charts!)


On the other hand Backtest settings - General - Periodicity will show only intervals being equal or longer intervals than set Base Time Interval (even if your imported data is of higher granularity (e.g. 1-minute) than set Base Time Interval (e.g. Daily)). So if you have imported 1-minute data then check whether in File - Database settings - Basetime interval it is set to 1-minute too! Then go back to Backtest settings - General - Periodicity and you will see that intraday intervals of Tools - Preferences - Intraday will be shown there.

Another important thing to keep in mind is that Chart interval setting and Analysis interval setting are independently set from each other! Analysis Interval is set in upper mentioned Backtest settings - General - Periodicity only (see picture below).

3 Likes

@fxshrat,

Thanks a lot for your detailed explanation!!!

After changing the base time interval, issue is resolved.

Regards,
Sekhar