Bad 'Integrity' data plugin causes problems, was: Exploration errors!

On my new computer, Amibroker cannot explore all of its shares. The watchlist can only be limited to 100 shares, is it because I installed 2 versions of amibroker 64 and 32 bith? Thanks

Unfortunately your question isn't clear enough and does not provide all necessary details to give you an answer. Please follow this advice: How to ask a good question

There are no limits on number of watch lists and whenever 32-bit or 64 or both are installed doesn't matter.

Every time you explore all stocks, it will be stuck at 95%

@Beuty,

If you are having a problem, why not post your code (use Code blocks "</>" ). Then we can give it a try and see what might be the problem.

I've tried all of the AFL, but I can't. Including Afl which is very simple like this : `Filter=1;

AddColumn(O,"Open");`

@Beuty,

Here is a basic exploration:

_SECTION_BEGIN("Exploration ");

SetOption("NoDefaultColumns", True ); 
Filter = 1; 
AddTextColumn( Name(), "Ticker" ); 
AddTextColumn( FullName(), "Name" ); 
AddColumn( DateTime(), "Date", formatDateTime );
AddColumn(C, "Close");

//SetSortColumns(1,2,3);
 
_SECTION_END();

Beyond that, you would have to start telling (showing) us your settings.

I would recommend you start with a watchlist with only a few tickers, and see that it works properly. Then scale up till you can reproduce the error.

1 Like

Again your posts lack essential information. You did not follow How to ask a good question

WE do NOT see your computer screen. We DO NOT know what data source you are using.

Guessing games is not the way to solve problems. It is waste of time. PROVIDE ALL INFO.

You may have corrupted database. If it stucks at the same place, one of data files may be corrupted. Create NEW database.

Is the "data source" of your database a "local database" ?
If it is not, set to "local database" and check if explorer ends.

Thanks for care :relaxed:

Whenever using Intraday data feed from plugins in both 32 bit and 64 bit versions, it always gets stuck: if explorer all shares. Even though on other laptops it doesn't matter, only on this new desktop.

But if you use EOD data from import asci, it's fine and works well. Thanks

Are you sure you have the same list of symbols in both computers ?

I had a similar problem, and found out that I had 2 extra symbols that
for some reason , the data server instead of anwering that it had no data for them,
it just let the plugin waiting for timeout.

You just prove that they are different, :sunglasses:
image

3 Likes

Here is your SOURCE OF PROBLEMS. You are using unauthorized 3rd party plugin that STUCKS while trying to download data.. The PLUGIN is wrongly written because it blocks, while plugins MUST NOT BLOCK. Requests MUST be handled ASYNCHRONOUSLY. Complain to PLUGIN VENDOR, not here.

Our own plugins never block.

Use only plugins listed here: http://www.amibroker.com/guide/h_quotes.html

3 Likes

How come my old laptop can ?, and it's so fast. Exploration only 7 seconds.

Thanks Mr. Tomasz

I have 3 Intraday Plugins, all on New Desktop Stucks. Even though on my old laptop everything could be used. I wonder why and what is wrong? Please help with the solution. Thank you

Despite having been asked many times, you did not provide the NAME OF PLUGIN VENDOR. ("Intraday plugin" means nothing). Send a screenshot of File->Database Settings.

Did you try to remove the extras symbols ?

You are using UNSUPPORTED 3rd party plugin from INTEGRITY and the plugin is getting stuck doing some remote request. Unsupported means that neither I, nor this forum supports it, because we can't, since we did not see your plugin even ONCE.

The problem has NOTHING to do with AmiBroker. It is PLUGIN problem. Nothing in AmiBroker can be done/changed with regards to the problem because it is solely PLUGIN problem.

What you should do is to:
CONTACT DATA VENDOR (INTEGRITY) to fix plugin or fix data or both

Neither I, nor anyone on this forum, can fix DATA/PLUGIN VENDOR problems.
We do NOT have Integrity plugin to test, neither anyone on this forum.

So YOUR ONLY solution is to contact PLUGIN VENDOR.

1 Like

Topic is closed. Original poster uses UNSUPPORTED, UNKNOWN 3rd party plugin and it has errors. The are two solutions:

  • REMOVE 3rd party plugin
  • FIX 3rd party plugin