Cannot remove "use extended trading last price"

When I had setup amibroker a few years ago, I somehow clicked "use extended trading last price" in database settings --> configure. I just noticed that for 30 minute bars in the 390 minutes of a 9:30 am to 4 pm trading day there should be 13 of these 30 minute bars but, in fact, there are 14. The last bar must be the extended trading last price bar.
I wish to remove this bar from my local database or at least suppress its appearance in my charts and in the AFL. I unclicked the box referring to "use extended trading last price" and then clicked "flush cache" on the main database settings menu BUT to no avail. I know this is a rather silly question but now that I've got myself into this pickle I'm hoping that someone can save me. Incidentally, I use IqFeed. Thanks in advance.

Check timestamps. If I remember correctly from when I had IQFeed subscription, they used timestamps so 9:30:00 was 9:30:00 to 9:30:59. So if your using 30 minute bars and you want to see 4:00 close, your going to need 4:00:00 to 4:00:00 to 4:00:59 bar creating that extra candle.

I remember with stocks my options if I wanted to use 1 minute data to compress to end of day, I either had to take the value at 3:59:59 as the close(which usually is pretty close to the last tick) or include the next bar into it which would put me at 4:00:59 and then my close would be 1 minute into after hours.

If you changed your trade times to 3:59.99 it would eliminate that extra candle. But as I said in paragraph above might not be what you want.

Metamega, thank you so much. setting trade times from 9:30 to 15:39 did the trick.

Whoops! I meant setting trade times from 9:30 to 15:59 did the trick.