Cannot save database because index.txt file is not open for writing

I have used CSI Data to feed market data into Amibroker for several years. Recently, I was trying to set up a backup computer, but I can't get it to work correctly.

First, I tried copying everything from main computer to my backup computer. That didn't work correctly.

So, I have tried uninstalling and reinstalling Amibroker several times. I made sure to register Amibroker each time. I made sure the CSI Data has the correct Amibroker database folder to write to.

The error I get is:

This prevents me from saving any symbol information. And, if I close Amibroker, all of the data from the CSI import is gone.

However, in the file path in the error message, the folder "Watchlists" does not exist.

Based on the recommendation of a similar post with a similar issue during a Nordgate import, I contacted CSI Data to see if they could help. Their response was:

"UA writes the data to their database. We do not work with their ..\WatchLists\index.txt file."

How do I fix this issue?

There is something wrong with your setup. Watchlists folder should be present. You can create it manually if it is not there.

I'll try adding it and see what happens.

The Watchlists folder is now present.

The index.txt file is in that folder.

I reran the import and got the same error.

Did you create that file yourself? How come it is there when you got the message it can’t be open for writing.? Something is seriously wrong with your system, like antivirus is playing games, or you did not run full setup in first place, file is read only or locked by another process. Get hands-on help from somebody who knows computers, because forum is not really good vehicle for solving individual computer issues.

1 Like

The issue may have been because this was a back up computer that was previously a work computer. I completely wiped my hard drive to my sure there were no permissions or settings issues from work and reinstalled everything. It works now.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.