Chart starts drawing early

Trading session starts at 9:15am. And, from 1min to 5min intervals, the chart shows time of first bar accurately.

But when chart is switched to 10min and above, the first bar formation time does not start at 9:15AM.

  • For 10min interval, it shows 09:10AM as start time.
  • For 30min interval, it shows 09:00AM as start time.
  • For hourly interval, it shows 09:00AM as start time, and so on..
    2022-05-08 21 50 40
    2022-05-08 21 49 52
    2022-05-08 21 48 57
    2022-05-08 21 46 38
    amidb settings

The db settings and chart start time are shown in the pictures.

This might have been asked before but I couldn't find the guidance to help with this issue. Please guide so that charts can start as per the db setting.

@beppe Hi. Could you please help and guide?

Check whether you set per group intraday settings for your symbol some time before.
Per group intraday settings override global intraday settings.
So that may be one cause.

Find out the Group your symbol is part of and then go to Symbol - Categories - Groups, click on that group there and see if it ("Group uses own intraday settings") is checked or not. If it is check then uncheck it there or leave it checked and change intraday settings there.


Next time please post better picutres that actually show intervals!
It is not guessing show on TV.

BTW, are you actual member?
Your profile is hidden so one can not see "License verified" badge.

Tried your suggested way.

Few symbols were in groups (without exclusive intraday settings, moved them to 255 anyway). Two groups genuinely require different intraday session time settings.

No other group has any separate intraday settings.

However, the symbol I have opened on the chart is not in either of the 2 groups with separate intraday settings.

The symbol is NSE Nifty Index that starts at 09:15AM and ends after 15:29PM (just as per db settings). Sharing the screenshots again for your reference.


And, I did not bother to see/remember what info privacy settings share/hide. Of course, I am a member.

@vtriv what are your settings in this tab of the "Preferences" dialog?


1 Like

@beppe Thanks! I let a personnel from data-provider set this up for me. This was what I was missing the whole time. Thanks again. :slightly_smiling_face:

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.