De-Select ETF Stocks in Explore Results

Hello Folks,

When I run an explore in AmiBroker I get a set of stocks which include a lot of ETFs. I don't want these. Is there a way to 'code in' a filter in my script that will prevent ETFs from being inluded in my result list?

Many thanks for any and all responses!

No programming required.

If you have Sector/Industry classification then simply exclude Exchange Traded Funds via Analysis - Filter - Exclude (see picture below). Alternatively move ETFs to a watchlist and exclude that watchlist instead.

13

Then save to Analysis Project file (APX) via File - Save...
Project files save AFL and all analysis settings.
So whenever you want to run Explore you just have to load project file before and next hitting explore and that's it.

1 Like

Hello fxshrat,

Thank you for your constructive reply. It looks good, however, when I try the filter there is no 'Exchange Traded Fund' option when I click on 'Industry'. Any idea why?

Again, many thanks!

You have to read entire post carefully.

https://www.amibroker.com/guide/h_watchlist.html


As for categories please read manual e.g.
https://www.amibroker.com/guide/h_categories.html

@kwinana4379 - really, this forum features such amazing innovation called "SEARCH". You will discover a whole new universe if you start using it. For example a simple search for etf discovers this:

1 Like