Display multi time frame interval in view menu bar

I have gone through the post - Customising chart sheet time frame lists for faster access.

Tring to create time frame lists , but have got stuck when adding the "5-hour interval, as it does not show up in the "VIEW MENU - Intraday" hence this post:-
now the explanation !

1]. I have selected the time frames, kindly see below;


2]. added hourly, 1minute, 5minute and 15minute intervals to the "VIEW MENU", see below:-


  1. 5hour interval shows in the drop down menu :



Ihave tried a screen capture using "screen to gif" & the "snipping tool" but when I click to start these programs the "view menu disappears" !

Can any one help me to get the"5hour" interval into the view menu-- intraday section,
the other intervals worked OK, why this "5hour" interval is not workig??

TJ has in a few posts mentioned why the toolbar menu should have only a small number of entries for good UI design. (Scrolling menus are bad design)

Maybe all the options are not being added otherwise the list will be very long, try adding the 5 hours to position 3 or 4 and then use drag-drop in customize to create your button and re-arrange the custom intervals as before.

Currently, 5 hours is at position 5, move it to where 15 min is and try.

I don't understand that. 1m, 5m, 15m, hourly, daily, weekly and monthly intervals are available by default after each AB installation (out of the box):

1 - available by default

So you don't need to add them to Custom time intervals! In your case you only need to add 5h to Custom time intervals and create a toolbar button for it. See here:


Could also consider hot keys. One of my favourite parts of Amibroker. I use Ctrl+d for daily, ctrl + w for weekly. I use alt+x to return to default zoom which is handy when zooming in and out a lot and flipping through charts.

Some like to use a mouse but I find hot keys so much easier and convenient once you get use to it.

Thanks , I have tried your suggestion, still did not work, then I selected all [1 to 5] as 5 hour, see below

but it still does not work.

@ Milosz,

Thanks, I use 2 separate installations of Amibroker, one for intra day and the second for EOD data ,here I have selected, daily, weekly and monthly for the view menu.


Thanks, but like you mentioned, some like to use a mouse - guess I am one of those!

Anyway the issue has not been resolved - life continues.

Once again thanks for responding, I will keep trying and if I get a solution will post the same.

which version are you running ?

Can you post a screenshot of :
Menu toolbar > View > Intraday

In customize mode, you are supposed to drag it from here and drop it on the desired menu.

Hope you are referring to intra DB and setup of AB for this.

One of the easiest ways of capturing the "disappearing menu" is using keyboard shortcuts in screenshot utilities or making a default windows printscreen (Ctrl + Printscreen or Fn + Printscreen etc.) and (if necessary) editing/cropping the image.


As you can see, I have no problem with the additional "5h" toolbar button...



Thanks --------------------many, many thanks.
Over the past year I have learnt a lot from you, so once again, gratefully - thanks a ton.

Firstly I was not aware that an image using print screen could be posted on the forum --- will try it
next time.

The solution to my issue came from using "REGEDIT" as explained in the link
you have posted.

Once again thanks .

1 Like

sorry, missed out posting a reply to your query.

I am still using ver:6.28.

solution came from using "REGEDIT" as explained in the link posted below by @Milosz.

Hi, Good Morning. I tried the steps as suggested by you.

  1. REGEDIT used for deleting the files.
  2. I have 2hr, 4hr intervals in tools, prefrerances
  3. I have dragged & put into views in customization mode.
    4hr interval disappered from view-intraday. see the attached screen.
    4hr interval TF did not appear in the view

Am i missing any step? is the above procedure is correct?



  1. I didn't suggest using REGEDIT to delete any files!
  2. In your case you don't even need to enter UI customization mode.

All you need to do, is defining custom intervals in Tools --> Preferences ---> Intraday and those custom intervals will show up in the View --> Intraday menu automatically!


BTW You have asked above aquestion (and I have replied) in this thread:

Milosz, what you said is correct.
My intention was to have 1hr,2hr,4hr in the following menu at the place of 1min,5min,15min which i am able to add.

Hence, my request is to change intervals 1min,5min,15min to 30min, 2hr,4hr (1hr is already availble). I trade on 1hr TF & above, rarely i trade 30min.

Appreiate your help.

I really don't understand why you have problems here. It's very simple. In your case you only need to create three custom intervals (30m, 2h, 4h) and (if you want to) additionally create three shortcuts to them (toolbar buttons). As you can see on the right side of my screenshot above, I have shortcuts to five custom periodicities (2m, 3m, 10m, 30m, 3h) - so it can be done. It is all described in the first two links I gave you in my first reply in your other thread and in many other places. Similar topics have been already discussed on this forum. Here they are once again:


Please see attached screen. I created TF intervals in tools-preferences, saved them. Then exited amibroker, then opened amibroker, but they are not appearing in the view-intraday. Is problem with version 6.20.1?


Check out reset button of tools - customize - toolbars - menu bar.
And if you want to enable tick intervals then check out file - database settings and select tick of base interval.


Hi Milosz, issue resolved, thanks for help. Have nice week end

1 Like

Hellow, I done multiple time frame intervals settings on the view menu bar for 1hr,2hr,4hr successfully. And saved all. When i open amibroker nextday, old view menu bar is displaying. 1hr,2hr,4hr TF are gone.
image .

I will chabge it to 1hr,2hr,4hr TF again, but how to save it permanently?

Hellow, I have done changes as suggested for 5hr interval. Saved all before closing amibroker.
After i exit amibroker & open next day, 5hr interval disappears & only old default view appears.

Am i missing something to make changes permanently?

If they are missing it means that you don't have write rights to registry or to AmiBroker folder. This could be if you did not run FULL SETUP in first place.

Make sure that you don't have VirtualStore folder like this:

C:\Users\*current logged in user*\AppData\Local\VirtualStore\Program Files (x86)\AmiBroker

If such folder exists, it means that your AmiBroker was NOT properly installed in first place.
Existence of such folder means that writes are redirected by Windows to wrong place (VirtualStore)
and they may cause all kinds of troubles including inability to save new content.

To fix that you need to:

  1. Delete Virtual Store folder
    C:\Users\*current logged in user*\AppData\Local\VirtualStore\Program Files (x86)\AmiBroker

  2. Run FULL SETUP of AmiBroker