Download OK, no chart

I am at a loss here, I have browsed all the topics and the knowledge base and cannot find my problem.

I have created a new list of US stocks for download. The download seems to work fine as I can see it Amiquote and I can see that the date is current if I navigate to the downloads folder (using ticker TLT as an example).

Using an older stock list e.g. ASX200, the download works fine and the charts update to the current date. However with this new list the tickers just bring up a blank chart. I have tried all the manual import suggestions, auto-import etc, nothing is working.

I'm sure it's a simple solution but I can't find it!

Have you tried Tools > Cleanup database?

Unfortunately your question isn't clear enough and does not provide all necessary details to give you an answer. Please follow this advice: How to ask a good question

You have to send screenshots showing EXACTLY what AmiQuote displays.

Without screenshots it is guessing game.

The message "Download completed" means that it is downloaded, but it does not mean they are imported. You would need to see "Import completed" message. And that would only occur if "Auto-import" is checked AND AmiBroker with correct bitness is running.

UPDATE: other things to consider:

First please read

Are you using by chance 3rd party plugin (like Norgate) then the plugin controls data entirely.

If you are not using plugin, you can try importing manually
using File->Import ASCII
and then you will see errors (if there are any)

Thirdly, your database folder or individual files may be marked as "Read Only"
and/or corrupted by antiviruses.

If you observe bizarre behavior, first thing to check is antivirus they are really nasty nowadays.