Drawing tools shift

Hi everyone,
I have strange problem - I draw an object from Draw or Fibonacci & Gann menu, when I go to its properties and confirm with OK button (doesn't matter if something was changed or not) my drawing is shifted one bar forward:
draw

This is happening only once, next properties change doesn't shift the drawing. Also when I click Cancel button, nothing happens.

Any idea how to fix that? I don't want to move drawings all the time...

Thanks & regards,
Patryk

Hello @patryk
Can you tell us what Amibroker version you are using?

Hello,
yes, I missed this information - I'm using newest version 6.39.1 32-bit on Windows 10 but with version 6.30 was the same.

You have to wait for @Tomasz to Answer you about this Question. I just test the magnet and work perfect (win7 AB x64).

Tomasz, Please note that in @patryk previous thread he had some problems also with that lines.

bi= barindex();
x = GetCursorXPosition( 0 );
barNo = Lookup( bi, x, 0); 

Well, to be honest, it happens the same with or without the magnet. And with regards the code you pasted, the new code responsible for removing drawings you provided works but I have to point place one bar on the left from the circle used for removal. So this is connected.

Either your database has incorrect timestamps or incorrect setting is in Tools->Preferences, "Intraday" tab or both.

OK, then I need your help, I don't see what can be a problem. My settings are:

database
preferences

Go to Symbols->Quote Editor and show actual data (make the screenshot wide enough to include ALL columns and all timestamps (without truncation).

Also: Mixed intraday/eod mode should not be used if you have End-of-day database.

Tomasz, here is screenshot of quotations:

quote

As for EOD/Intraday, please advice which to choose. I'm using Statica plugin. Usually I check the chart in the evening after the stocks are closed and I don't use intraday charts (yet). But sometimes when I'm home, I check chart during the session, that's why I have mixed intraday/eod mode on.

We did not write the Statica plugin.
Anyway turn OFF Mixed intraday/EOD. It should only be on when you have MINUTE data and End-of-day data in the same database. This setting has nothing to do with updates during the session (it will update daily bar anyway).

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.