DTN Iqfeed / Ubuntu

Hello,
i'm trying to get amibroker with the dtn realtime api working on Linux, i can get both amibroker and DTN/iqfeed to work independently and receiving quotes to the DTN apps.
When i load up the correct database amibroker initiates the the IQconnect app and it connects fine, the icon moves to the taskbar/tray. But the amibroker icon never goes green and says connected, when i hover over the plugin status it says:

"Trying to connect to iqfeed on port 9300"

the IP's i got from iqfeed support for my firewall are
12.36.218.128 :60000 - > 12.36.218.254 and 60060

does anybody have any idea how to get them to connect, or what i should do with the port 9300 bit?

IQFeed support does not know their own product. They told you wrong. You have to enable port 9300, 5009, 9200, 9100, and possibly others as well.

https://www.google.com/search?q=IQFeed+port+9300

added all those, didn't seem to make any difference

Hi @kastin
try to enable ports 7050, 7051 and whitelist IP addresses 66.112.156.* 66.112.148.* ports 5000-5050, 60000-60050. Good luck.

this is a copy of my firewall now, think ive got everything covered, but still nothing.

Screenshot from 2022-06-28 19-30-51

If you are on Linux, you should be able to configure firewall to LOG connection attempts and rejections. From there you will find what is being blocked. This is not Linux forum. Ask how to use firewall on Linux forums.

Yep i understand this is not a linux forum, just hoping to lean on the knowledge base here and hopefully add a solution to others with the same issue later.

i have tested and checked my UFW logs on low/medium/high, there doesn't seem to be anything being blocked other then a few local router destinations.
and logs looked the same when i tested by loading iqfeed diagnostics/snapquote
or opening amibroker and letting amibroker connect.

I've also monitored the packets with tcpdump from both my local ip 127.0.0.1 and from my wifi router's ip 10.20.111.95 and the only connections are to the
12.36.218.144.60000:60050 range
and maintains the same range when i load Snapquote and receive quotes through the iqfeed apps.

the only reference to 9300 is below from my pc to my pc, should i enable these source ports too?
SPT=51895, SPT=39361

Jun 29 18:46:59 Klap9360 kernel: [24544.533207] [UFW AUDIT] IN= OUT=lo SRC=127.0.0.1 DST=127.0.0.1 LEN=60 TOS=0x00 PREC=0x00 TTL=64 ID=10249 DF PROTO=TCP SPT=39361 DPT=9300 WINDOW=65495 RES=0x00 SYN URGP=0 
Jun 29 18:46:59 Klap9360 kernel: [24545.429641] [UFW AUDIT] IN= OUT=lo SRC=127.0.0.1 DST=127.0.0.1 LEN=60 TOS=0x00 PREC=0x00 TTL=64 ID=48322 DF PROTO=TCP SPT=51895 DPT=9300 WINDOW=65535 RES=0x00 SYN URGP=0

Yes, many IQFeed connections are LOCAL connections (i.e. from application to IQFeed client program running on SAME machine). I would advise allowing all connectivity with SRC and DST being 127.0.0.1
Local connections are safe, nothing is leaving your PC.

DTN IQFeed API is provided by DTN under NON-DISCLOSURE AGREEMENT. We are legally binded NOT to discuss IQFeed API in public.