Embedded ASCII format commmands not overriding default format

Trying to import thousand of files with its own format through the ASCII importer. For example:

I've deleted default.format file.

But Amibroker still complaints:

What is the proper way to make the embedded format commands override any other default format?

Your assumption is INCORRECT.

Embedded commands are interpreted correctly and data would be imported just fine, if you just did not include $BREAKONERR 1

The error is generated by ONLY BY SINGLE WRONG LINE in your file that does NOT include quotes.


All remaining lines are read correctly.

And no $SKIPLINES 1, doesn't skip that because it skips FIRST line of data file and that line is not first.

You have two options:

  1. Use $BREAKONERR 0 to ignore that error and import the rest normally,
  2. just remove offending line from data file.