Error when trying to import Yahoo Fundamental Extra New

I have started to get this error when trying to use the Yahoo fundamental data.
Screen Shot 2022-07-20 at 8.50.18 am

It was previously working but now is not.
Recent actions that I have taken were to start using the Tradingview data plugin which is great, but does not include fundamental data.

My solution therefore was to go back to my local database for fundamentals and have a different instance running for intraday.
I generated the local database originally using free EOD data from Yahoo when I started using Amibroker a few weeks ago. I have opened the old database (which is just a local database, no plug ins) and I have also changed the path in preferences to point back to the initial database. I get this error whether I am running 2 instances, (1 intraday with the plug in and another local database without) or whether I am running the local database by itself.

Other data sources are working fine (e.g the Yahoo Historical EOD) but when I try and use the Yahoo Fundamental Extra New, I get the above error.

I re-downloaded the
data source created by Tomasz and replaced the file in Amiquote but that is not working.

Another thing to mention which may have caused the error (I'm not a programmer, so please go light) is that I have been experimenting with running batch processing today. I have only tried a coupel of things, using the execute and wait action. I managed to get Amiquote to launch and start running using the action, but it was set to the Yahoo free EOD source. It was when I switched the data source into the fundamental extra new, that I started to run into problems.

Any advice is greatly appreciated.

The message is quite obvious you don't have Microsoft JScript engine present on this machine.

It was previously working but now is not.

Apparently you have either uninstalled some software that removed JScript or installed some Windows Update that removes JScript or antivirus has gone crazy and removed JScript from the system.

I've checked 3 browsers and Javascript is working fine in all 3 of them. Is it still possible that it is not working at the machine level?

The plug in I am using is here and the support guy seems nice enough. The plug in gets all of the OHLC and Vol values from pretty much anything you can find in Tradingview and it works really well. It doesn't appear to have Fundamentals/financials data though, so I was trying to import fundamentals data into that database.

I am wondering if perhaps I have misunderstood something....

If I am running a live data plug in to lead up a database, can I use Amiquote to import other data into that database, or does the user need to choose between plug in and Amiquote?

Progress;
Ok, so I have tried replacing the JScript.dll in C:\windows\system32 and also in C:\windows\sysWOW64 that was ineffective in both instances.

I have created a new virtual machine from the disk image that I created (Pro Insider preview, Evaluation copy. Build 25163.rs_prerelease.220715-1711) but immediately paused updates. (Note, this is the only copy I could find which works on parallels for Mac running on Apple 64bit M1 machines)

I the installed a new instance of Amibroker, and have imported quotes via AmiQuote, and then I have run the [OBSOLETE - Removed. Download AmiQuote 4.13 instead] data source and it works fine now.
To test if it was anything to do with the plug in, I ran an unregistered version of the Tradingview plug in and then later retried the Amiquote Fundamental data source, and that works fine.

So I have narrowed down the issue to something occuring in the windows updates somewhere between 'Pro Insider preview, Evaluation copy. Build 25163.rs_prerelease.220715-1711' and now.

I have reported the issue to Microsoft. Hopefully they address it, as its a nuisance.

Hopefully now I can get to the learning of afl and creation of systems with all of this beautiful data!!

There have been problems with Parallels on M1 Macs with regards to OLE automation. Make sure you are using very latest parallels version

1 Like