Force backfill avoidance

Everytime i revisit Amibroker window after a gap, i will have to force backfill manually to get the realtime live data reflected for my symbol...how do i over come it and ensure my charts are always live/real time with out manually hitting force back fill?? just like the way live charts get updated in say Inteactive brokers

I guess there is no solution for this - other than what i am doing (manually clicking "force backfill")...
I just wish - it says loading... and i know it has all the latest data...

Our own plugins do NOT require that. They backfill missing data from last update automatically. What data source are you using?

IQFEED data source real time

As I wrote, you are doing something wrong (not as described in manual) as our plugins automatically backfill data from last update to current date/time without requiring of any "force backfill" at all.

I am not sure what i am doing wrong...I am copying the plugin and database settings here and the output i am receiving here - hopefully, i can get this fixed:
DB%20settings fbackfill-2 fbackfill-1

The screenshot just shows that data are backfilled correctly.

If you see the 4 hr time frame windows - the bars arent complete; If i force backfill, the bars are complete like you see in other time frames.
In some instances, like second screenshot, no bars are populated for 4 hour and 1 hour timeframe charts - those charts should look like what you see in daily and 5 mins charts.

Force backfill does not differ from normal backfill. It is the very same code. What force backfill does is to delete existing data so entire history is downloaded again instead of downloading just missing part from last update. But the backfill code is the very same. The difference is only in "start" date.
Maybe you have local problem with access rights because setup wasn't run properly. Or your antivirus is acting up, or you are using limited user account that does not allow to write data to "Program Files". Check your privileges, or install to directory where the user account you are using has WRITE access. Check antivirus - it is not uncommon for antiviruses to cause all kind of weird issues.

Oh yes - I use work laptop and i do have anti-virus in there; I wonder what to look for in MacAfee settings and ask our IT folks to change/help - Any idea?

McAfee - the worst antivirus ever? Bad Image (0xC000020) error - McAfee gone mad

Wow...i guess i will have to get and use Virtual private server (VPS) to overcome these limitations.
I guess that will be fine as i can run Amibroker on that VPS 24*7 and that can even ensure i never miss alerts.

No you don't need VPS. Everyone else is running without problems. So install official version 6.20 and create new database exactly as in the manual.

Thank you- it is working well in my desktop , where there is no Macafee anti virus , but causing these backfill issues on my work laptop which has Mcafee anti virus;
But i do travel quite a bit and will need to have flexibility - not sure if there is other option other than VPS or a new personal laptop..!

Windows built-in Defender is BETTER than McAfee and does not create all the problems that McAfee does. General recommendation is just use Windows built-in antivirus, not 3rd party. Less 3rd party software means less problems.
See AV test:
https://www.av-comparatives.org/tests/real-world-protection-test-september-2018-factsheet/

Finally - i was able to do this in my desktop with no antivirus software - however i still see the issue - pls see attached screen shots below.

backfill%20issue-%20before%20FB
backfill%20issue-%20after%20FB

Also, when i wake up my PC and see Amibroker - the latest bars dont come up - until i click force backfill and Ninja trader shows "loading..." that tells me it is loading - but i am not sure what Amibroker is doing and i have to manually check the time stamp of the last bar to see if it is the latest bar

Arghh..... why people do NOT provide important information in first place???

You "wake up your PC" ... so you put your PC to sleep or hibernate?? Why did not say that in the first post ?

In Windows Sleep/hibernation means that ALL internet activity is disabled plus program effectively gets FROZEN and does not use CPU at all, so it can not do anything.

Don't put computer to sleep if you want real time data to be updating your charts.

If you want to save power - turn computer OFF. Then switch it on and run AmiBroker again -- then it will backfill missing data automatically on START of application. FIRST access (after start) is the only moment when it backfills automatically missing data.

If you slept/hibernated your PC you need to restart the app to get automatic backfill again.

3 Likes

@uvdsatish probably an alternative option is switching to local database before putting your PC to sleep and switching back to your plugin after resuming your work.

At least I always save my database and switch it to local before putting my PC to sleep and I've never had any problems with automatic backfilling data when resuming my work. But I'm not using IQFEED - that's why I started my reply with "probably".

1

1

BTW it is always better to run backtests, explorations etc on a local database as these operations will be performed much quicker.

3 Likes

Yes it will also backfill after reconnect.

Hi,

So can I confirm it's ok to switch my IQ Database to "Local Database" and then switch it back to "IQ Data Plugin" at a later point?

I'm finding that when I run a backtest on stocks AB is backfilling all stocks in the BT as it runs. If that is normal, perhaps I could change the database to local - perhaps it might help with some issues I'm experiencing? Thanks (I could explain the issues in another post)..