Format files folder

Sorry but I can't seem to identify the folder where the Ascii Importer stores format files. My edited format file does not appear in the Importer file dropdown. I have tried pasting the file into all AmiBroker folders that contain format files but that didn't work.

Any help appreciated.

Under the Amibroker main folder, there is a "Formats" folder. drive:\path\Amibroker\Formats

You can place your .format file there, eg. custom1.format

Then look for the special file called import.types

Default ASCII (*.*)|*.*|default.format

It has the following format that you specify so that your format appears in the dropdown and you can also specify a pattern to filter those specific data files you want.

An example could be

NSEdaily (nsedata*.csv)|nsedata*.csv|NSEdaily.format

This filters all csv files beginning with nsedata like nsedata210701.csv
The actual import definition is stored in the NSEdaily.format file in the Formats folder.

1 Like

Why repeating everything that is explained in AmiBroker knowledge base

As well as is existing in forum already too?
https://forum.amibroker.com/search?q=import.types


For creation of format file you do not even need to lookup folders.
You just have to check "Add current settings to ASCII importer defintions" of Import wizard as seen in the KB article of first link.
imp

Thank you very much. Adding the file to import.types is what I forgot to do.

Much appreciated. :slightly_smiling_face:

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.