Getting error the batch file

I was trying to automate a batch to run every 5 min used ShellExecute("runbatch ..... Failed to succeed.

now getting error the batch file specified in the command line does not exist...
tried deleting the afl and the batch and apx from the folder still getting error

too late for fix .... reinstalled AB.... :rofl:

Reinstalling is not magical cure for everything. AmiBroker does not "disintegrate" by itself and does not require re-installs.
The error messages typically mean what they say, if you are getting "batch file specified in the command line does not exist" it means that really there is no file in specified PATH. Which may mean that

  • you typed the PATH (directory) wrong, or
  • you did not use proper backslashes (remember in AFL single backslash needs to be written as \\ )
  • or the file name is wrong (simple typos like lower case 'l' (London) instead of uppercase 'I' (Icecream)) These letters look the same yet they are different.
  • or the file name has wrong extension
4 Likes

@Tomasz "The Tomasz" replied for the first time on my post ... Thank you for the guidance.

Actually I had every thing typed in correct, dont know where I was going wrong
This is what i did:
Created a test afl to explore then created the .apx file
created a batch load file explore export
created another afl with the runbatch .....""1);
while runing the afl it triggered the batch and did what i wanted it to do that is export a csv file, however ran only once and not every 1min which I wanted
now the problem, i was facing was when ever i tried to close the analysis window it poped out and said another batch running and would run again and wont let me close the analysis window
So i removed the 1 from the runbatch afl and got in a loop wich would never stop.

clueless posted here ... hardheartedly reinstalled AB :slight_smile:

was trying to perform somestunt which @abbruiser mentioned

Can you reproduce the issue?

On a lighter note, atleast this time you will know to fix it in a worst case scenario :rofl:

1 Like

@travick I can recreate the issue and I know the fix which is very simple then reinstalling the AB....
only thing I dont know is how to run the batch every 1 min without any issue :slight_smile:

How long (in seconds) does one full cycle of the batch take to complete?

@travick It takes just 10 sec to Load Explore and export , those are the only command for batch.
Created another afl ShellExecute( "runbatch", "Test.ABB", "" ); to trigger the batch
what I am missing cant make out

It works for once, however wanted it to run every min.
And with the above code am not able to close the analysis window even after stopping the explore... the batch runs again , just does not run every min

You should post/upload the files here. You're still making me (& others) to assume and guess a lot.

Provide details of AB and bitness/ OS version etc

@travick could you explain the right way then me uploading everything :slight_smile:

I can't read minds :slight_smile: so until your purpose isn't clear, cant figure out what your doing wrong.

The Right way is already very clearly explained in the Manual.
If you are creating an infinite recurring loop, then you should fix that.

1 Like

Read ALL the KB...Gave up on run batch :slight_smile: Scheduler works and @fxshrat is the best and I am still Happy!!

1 Like