Having an issue with Report Explorer

I am having an issue with Report Explorer in AmiBroker in both the 64 bit version and 32 bit version.

I am running Ver 6.20.1 on a Windows 7 Professional machine. After a backtest I can click on the report icon and the report window pops up without an issue. If I open the Report Explorer and click on that simulation and and then click on the Report icon, I get a popup message that says"Detailed report not available. You would need to turn ON “Generate detailed reports for each symbol in individual test’ checkbox in AmiBroker’s AA Settings/Report to make individual reports available”. If I try to click on any previous recent backtest reports, I get the same error message.

I have another computer, a laptop, running AmiBroker Ver 6.20.1 on Windows 7 Professional. I opened Report Explorer and was able to view some old simulations. After I ran a new simulation on this machine the problem described above appeared only on the new simulation. I was still able to view the old simulations in Report Explorer. So it is only new simulations that seem to have an issue. If I go into Windows Explorer, I can see the reports in the Reports folder and can click on them and see the information is there, even on new simulations, but Report Explorer just can’t open it on new simulations.

Even if I do as it says in the popup box and turn on “Generate detailed reports for each symbol”, I still have the issue.

I have tried rebooting my machine, I have tried reinstalling AmiBroker, but no improvement.

Any help would be appreciated.

I think I solved my own issue. It appears that there is an problem when using the % character as the first symbol in SetFormulaName. It seems to mess up Report Explorer. Once I removed the leading % symbol, Report Explorer started working fine.

1 Like

Thank you dyaklin for posting this! I too was just having trouble with the report explorer where I kept getting the "Detailed report not available" message when I found this message of yours, and your post helped me resolve my issue. I too had the "%" sign embedded in my SetFormulaName. Though in my case it was not the first symbol...it was just in the middle of the name....but once I removed the "%" symbol, the Report Explorer started working fine.

Please keep in mind that formula name is used as subfolder PATH in the Reports folder. Because of this formula name must only consist of characters that are ALLOWED by file system. %, *, /, \, ?, :, " and all that kind of special characters are prohibited in file/folder names. See https://stackoverflow.com/questions/1976007/what-characters-are-forbidden-in-windows-and-linux-directory-names and https://msdn.microsoft.com/en-us/library/aa365247

Your safe bet is using A-Z, 0-9, underscore and space.

I changed my file name and it now works but all the tests I ran before I cannot open (100's of them) anyway to change a setting so I can view previous reports? Never had an issue opening them before but all of a sudden I got same error message and had to take % out of my file name - so new reports are viewable but all the others are not.

You may be left with the requirement to rename them all.

There may be a (free or open source) utility that can bulk remove the special characters from the file names, or you may be able to write your own script to do it.

Hope that helps.