How do I locate this error?

I am running an analysis window and suddenly I saw this error message. But it does not help me locate the exact line where the problem occurs. Please see attached screenshot.

The analysis window project is just one line of code:
#include_once <>

I have windows 7, 64bit
Amibroker 64 bit , v 6.21.0

Run in the Analysis directly instead of #including it. You will get detailed location that way.
#include is intended for already tested error-free code not for work-in-progress

There is a reason why I used the #include statement for the file, instead of directly using it in the project. My project involves 4 analysis windows and everytime I open them I have to update with the new code. Marcin gave me the solution to use the #include.

This difficulty, not being able to debug easily the #include files, has made me reorganize my project a couple of times. I wish this was not an issue.

No, you don't need to do that. You can de-couple Analysis project from AFL file and share single AFL file in multiple projects by switching just one option:

yes, it worked as expected. Thank you very much.

I was able to see the line # of the error. However when I clicked on the "details" button, nothing happened.

I also noticed that when I set "keep existing afl file when opening a project" on one analysis window, it was set in all of them.

When I copied the APX files to another pc, I had to set again the "keep existing afl file when opening a project" .


  1. Click on the "Details..." button. AFL Formula Editor (with your code) should open. Now click "Verify Syntax" Icon ... You will get detailed information about errors.

  2. "Keep existing AFL file when opening a project" is the general setting for the whole AmiBroker, not for selected Analysis windows.

  3. You have changed it once (on the other PC) and you will not have to do it any more.

1 Like


  1. As I said, when I click on the “details” button, nothing happens.

  2. I had to set it again on the second pc.

Yes, I know these do not sound right, but this is what happened on my setup.