How to avoid output to the "E:\Work\Broker\Plugins\"?

This is a post to correct my previous post
(please cancel my previous post):

I've tried to build QP2 on Visual Studio 2019,
then it told me that "D8016 '/ZI' is incompatible with 'Gy-',
so I modified the project properties to '/Z7'.
Q1) is it correct to set up the "Debug information format" to Z7 for this project?
////
I found that if I don't create the folder "E:\Work\Broker\Plugins",
Then Visual Studio 2019 cannot build it successfully, so
Q2) Please tell me the way to avoid this QP2 project
to output the DLL file to the "E:\Work\Broker\Plugins"
(I found that it also generated a QP2.dll under the Debug folder of the QP2 project)
////
Thank you very much :smiley:

You are getting errors because Microsoft changed requirements for DEBUG builds, but not for RELEASE.

In DEBUG build, in Visual Studio, go to Project Settings and simply change options.

  1. In Configuration Properties => C/C++ => Code generation
    change "Enable Function-Level Linking" to "YES" (as it is required by Edit and Continue in VS2019)

  2. In Configuration Properties => Build Events => Post-Build Event simply remove the command that copies output file

Please note that this forum is not Visual Studio support, Microsoft is not paying us to support their software, we are NOT helping C++ coders here.
ADK is provided freely "as-is" without support services.
C++ coders are required to seek help in other places.

5 Likes

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.