How to avoide backfilling already backfilled script

On re connection backfilling starts from very first script.
Removing it from rt window also not work. I removed backfilled scripts from rt window, closed and reopened amibroker still it appears in backfill.
I am using IB GAteway and tried to backfill all 100 scripts. but if net issue or any disconnection happens either I have to manually back fill single scripts. or I have to do it from start of the list.

Saving the database and configuration of database settings helped me when I had same issue.

How to backup data from an external source

1 Like

It worked, I removed backfilled scripts from realtime quotes windows once its backfill complete.Then saved database hence I dont have to backfill them again, backfill start with remaining scripts in realtime quotes.

but another issue is bothering me now, If i left my pc while backfilling and few backfills already completed, but on disconnection or any other issue with IBKR. All data of already backfilled script remaining in realtime quotes went off.

Sounds like second issue is more of a connectivity or IBKR problem (which there are several) .

Perhaps this workaround from same link will help.
1ab