How to use Quandl.com

Hello Tomasz,

I tried to download from Quandl URC/NYSE_ADV and URC/NYSE_ADV
Amiquote gave a message that .format file is incorrect and that Amiquote needs to be reinstalled.
Can you please advise how do I import *.aqq files manually if they cannot be automatically imported because of the URC/ source??

Capture

Kind Regards
Richard

Capture1

As written in this thread already: you need to create your own import definition file to import from sources that you have added yourself.
http://www.amibroker.com/kb/2016/01/23/how-to-create-custom-import-definition-for-ascii-importer/

(it is advised to read the thread from the very beginning)

Thank you Tomasz for your reply.
I have read the thread from the beginning but, I may not fully understood the process.
Amibroker KB link has helped a lot. Thanks again.

Regards
Richard

ASCII%20importer%20definition%20file
Dear Tomasz and all. Thank you for all this information but I am still fighting to import my data from quanDL. I subsrcibed to Chinese stock prices (DY/SPA). I bought Amiquote, I have the quandl API etc.
My difficulty is to create my own import definition file. Could someone please help me (sorry- this is more a beginners question...)

China_DY_SPA
Here you can see the example data. All looks pretty easy...
AQQ_files

But I don't have a good aqq file, in order to create the missing "importer format definition file" in the import wizzard or the ASCII importer (aqq_dy.format).
Maybe I should import via a "tls" better? This works for me with common US-symbols like AAPL, MSFT etc, but not for any Chinese symbol yet.
Please help someone.

Additional question (once the import will work :slight_smile: For Chinese data: Do you think quanDL has better data or tiingo?

http://www.amibroker.com/kb/2016/01/23/how-to-create-custom-import-definition-for-ascii-importer/

Hi Tomasz, Can't AmiQuote be modified to accept input of a .Format file?

.format file is the instruction for AmiBroker, not AmiQuote.

Does Quandl / Nasdaq Data Link API key work with AmiQuote 4.1? I have a valid API key for continious futures but regardless of the symbol/code it will not download any bars.

Thank you,

MikeQuandl_snip

Double click on those lines to see the content. If there is any error message you will see it there.

If I try the default Quandl source, I receive this error:
$NAME SCF/CME_C2_FW
{"error":"Access forbidden."}

If I create a new source pointing to https://data.nasdaq.com/api/v3/datasets/. I receive this error:
$NAME SHFE_ZN2_OR
Error - QELx04 : You have exceeded the API speed limit of 20 calls per 10 minutes. Please slow down your requests.

It seems it does not like my Quandl API token but I can access data on the data.nasdaq.com site with my login and in my profile I see my token. I have copied the token and manually typed it in and get the same error.

The error is self-explanatory. You have made more than 20 download attempts per 10 minute. You have to WAIT

You need to be aware that since Nasdaq took over QuanDL they implemented new limits and you have to obey them.

I did change the setting to 60 minute and it always download 0 bars.

When I use the default Quandl source, I get the error "forbidden" but when I set create a new datasource, I get the error message re "limits", both using the same Key.

I will try again, in a few hours, and post the message.

Thanks,

Mike

See:

From: https://docs.data.nasdaq.com/docs/getting-started

Rate limits
Authenticated users have a limit of 300 calls per 10 seconds, 2,000 calls per 10 minutes and a limit of 50,000 calls per day.

Authenticated users of free datasets have a concurrency limit of one; that is, they can make one call at a time and have an additional call in the queue.

Premium data subscribers have a limit of 5,000 calls per 10 minutes and a limit of 720,000 calls per day.

I am not able to download any data. I will try again tomorrow so there is no issue with limits on one symbol. I am subscribed to the Stevens Continuous Futures Premium data.

Thanks for your help!

Mike

I waited 24 hours and tied 1-symbol, downloading 8 bars of data.

Using the user-defined method, I received this:
$NAME SCF/CBOE_VX2_EN
Error - QELx04 : You have exceeded the API speed limit of 20 calls per 10 minutes. Please slow down your requests.

Using the pre-defined Quandl.com method i received the "forbidden" message.

Quandl/Nasdaq says the API token is correct.

I am not sure where the disconnect is but likely with quandl.

Thanks,

Mike

I just created a free Quandl account and attempted to download IBM and receive the message after no bars are downloaded:

$NAME IBM
{"error":"Requested entity does not exist."}

Is Quandl working for other user using AmiBroker?

Does anyone have a R or Python script to download OHLC data from Quandl?

Thanks,

Mike

Apparently since takeover by Nasdaq QuanDL has changed something.
It will be removed from built-in source list because data sources that are not stable are useless.
I may re-introduce it as user-defined source as then it will allow adjustments without changing the program.

Thanks Tomasz! Off hand would you have an idea of the settings or url to try as a user-defined source?