IB real time data missing

hello,
I would like to ask you about help with my issue.

PROBLEM : missing real time data - the last bar creating by price (should be move up and down) in a chart. No data ( numbers ) in Realtime quote window ( only symbol name ).If I ask for backfill, I´ll get it. Without last bar. If I dont ask, the chart is not creating any more (it is dead until I ask for backfill)

IB real time data subscription : YES - CBOT and CME ( YM MAR 24-CBOT-FUT, MESH4-CME-FUT )
Farms connected : YES ( the numbers in TWS are running very well )
API settings : active X and socket client YES, IP : 127.0.0.1 YES, socket port : 7496 YES
Amibroker 6.40.4 professional edition 32-bit ( I tried 64-bit version too )
IB plugin 2.11
TWS API - last stable 10.19.02 ( the same problem with 9.7 )
TWS version 10.27.1d ( latest stable offline) , I tried 10.19 too posted here by owner, 981 is no more running
Java : 1.8.0_241
Antivirus : Panda (if I turn off - no change). the same is for windows defender (firewall)

Database setting:
image
image
Information about symbol : use only local database : NO

I tried to search in google, manual and this forum, but nothing worked for me :frowning: if any idea, I will be happy. if I forgotted something, I´ll add information.

thanks to everyone in advance
david

Try other symbols, like US stocks symbols (MSFT). Also contact Interactive Brokers and say that you are not receiving real time updates. Make sure that socket window defined in TWS is the same as in the settings because different TWS versions use different socket ports by default.

Are you using the IB Dictionary file for symbol translation?
Are you sure it's just the last bar that's missing? If you let it go, will you miss all the bars since the backfill?

Hello dawex,

I recommand to use AB 64-bit professional single instance running and AB has to be license installed.

  1. Reboot your Windows workstation, do NOT start TWS and do NOT start AB

  2. Check port 7496 is NOT used by any other running service in your environment

To do this you could use powershell and query, result runs into TcpTestSucceeded : "False"
In case of success you have to change port to for example 7497 in TWS and AB

Test-NetConnection 127.0.0.1 -port 7496

  1. Start TWS and repeat Test-NetConnection, now TcpTestSucceeded has to be "True"

  2. Double check Windows Region/Time and TWS Region/Time, please look at this post

https://forum.amibroker.com/t/ibkr-plugin-msg-timezone-issue-during-backfill/36968

  1. Start AB, check first IB connection state "green" and second Database - [ Intraday settings ], i use "Exchange Time" in my setup


  1. Open Symbol - [ Quote editor ... ], your time stamps should look

  1. If you have only (1) single quote entry, what timestamp is stored, please post screenshot ?

  2. In any case of trouble with ticker storeing now, delete/recreate new empty database and start from beginning

Best regards,
Peter

3 Likes

hello,
thanks for advices to all of you. I appreciate, that you spend your time and energy with new guys like me.
as Tomasz wrote somewhere : mostly it is a problem of TWS, firewall or antivirus.
I add one more : problem of the thing between the chair and the keyboard.

I had a wrong name of symbol :frowning:
if you write: YMxxxMARx24-CBOT-FUT , you will get backfill, but no live data
if you write: ymxxxmarx24-!cbot-fut (dont ask me, why I wrote it with small letters), you will get backfill, but no live data
if you write it proper : YMxxxMARx24-!CBOT-FUT , you will be happy like me (after more than month of searching )
x=space

so stupid problem and so much frustrating.
thank you so much

1 Like

General advice: with IB use UPPERCASE symbols.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.