Import Wizard help

I have a CSV file with ticker symbols and a number I'd like to be in the Aux2 position. Example:
HFC,101154
AAPL,121133
BA,153323
...
I'm using the Import Wizard and at the top I'm selecting Name and Aux 2 and skip for the rest of the dropdowns, then in the additional commands I'm using:
$FORMAT Ticker, Aux2
$SEPARATOR ,
$AUTOADD 1
$NOQUOTES 1
$OVERWRITE 1

And I've selected the no quotations box. When I run it, it appears to work, but then my Aux 2 field is still 0. I verify it by doing an exploration for Aux2, a plot of Aux2 on the chart, and the quote editor. I'm using a local database with quotes being updated by Tiingo. Any help would be appreciated--Thank you
Tony
I've also tried adding $HYBRID 1, but that didn't work either. I'm following the template for sector/industry import on the Import from ASCII file webpage as it appears pretty similar to my situation.

@Tony see this KB article:

Importing auxiliary data into AmiBroker database

The sample file there (that for some strange reason, is displayed in a single row) is as follow:

# This example assumes that file has format: # Symbol, Year-Month-Day, auxiliary_data1, auxiliary_data2
$FORMAT Name, Date_YMD, Aux1, Aux2
$HYBRID 1
$ALLOWNEG 1

So the trick is to use the Wizard, select the 3 fields (you NEED to add to your file the date where to import the Aux2 data) Ticker, Date and add the $HYBRID 1 and $ALLOWNEG 1 instructions.

immagine

4 Likes

Blockquote (you NEED to add to your file the date where to import the Aux2 data)

Although in brackets, this is the key. AB DB relates all data via a timestamp.
so if you just import Ticker and Aux, it wont make much sense.

2 Likes

Thank you @beppe and @travick, much appreciated!
Tony R

I am trying to import data from a CSV file into the Aux2 field of existing tickers similar to the above thread. The CSV setup is:

image

I am using the Import Wizard with the setup:

image

The import runs without errors but, when I open the quote editor, the Aux2 values have not been imported:

image

Any ideas on what I am doing wrong? Many thanks in advance.

In Database settings, what data source do you have ?

@P6Cats,

uncheck "No quotation data".

Tried that but result is the same, no Aux2 import.

Data Source is "Norgate Data Plug-in".

The plugin OWNS the database. You can't import to plugin-driven database http://www.amibroker.com/guide/h_workspace.html unless you import to symbols that are marked as "use only local database for this symbol"

1 Like

Tomasz - Thanks for the clarification. I get that now. Perhaps I can setup alternate tickers for the info that I want to import and then call that info using FOREIGN...I'll give that some thought.

awilson / fxshrat - Thanks for the efforts.