Intraday periodicity is available if your DATABASE is intraday, was: Custom Periodicity hourly

Hello! I'm new to amibroker. I tried to backtest in Hourly, I got 1min datas, but the options in backtester settings are only daily weekly monthly. I searched the forum and followed the steps (tools > preference > intraday), still I cannot see the 1 hour option. The backtest reports are always in daily.

As written in the manual:

Changing bar interval (periodicity)
Please note that intraday intervals are disabled if your database is in end-of-day mode. Intraday modes are available only for databases that have "Base time interval" in File->Database Settings set to anything less than end-of-day. If you for example set "Base time interval" in File->Database Settings to 5-minute, all chart periodicities from 5-minutes up will be enabled.

The same applies to Analysis window (backtest/exploration/etc).

So you have to select 1-minute as Base Time Interval in the File->Database Settings.

1 Like