IQfeed Client version

Hello,
is it advised to use latest IQFEED CLIENT version ( 6.0.1.1 ) or the one linked from http://www.amibroker.com/devlog/index.php?s=iqfeed which is 5.2.4.0 ?

Using:
Amibroker 6.30.5
IQfeed plugin: 6.0.5

Just use the most recent. Most recent versions are usually better as they have issues fixed and performance improvements. IQFeed client is not fragile because basically it communicates with plugin using TCP/IP using text so it is separate and not subject to any kind of binary compatibility.