IQfeed daily data only get data back to 2016?

I use iqfeed for getting daily data.
But I only can get data back to 2016.
I want to get 10 years data.
My amibroker version is 6.20.1 .
My iqfeed is 5.2.6.0
My amibroker's database setting:
ami_database
How to get 10 years data from iqfeed daily data?
Thank you.

Hi. This is the setting I have on my IQfeed and have started /stopped my service with them repeatedly with no issues. Hope this helps. I am talking about the IQFeed for $78 monthly.I stopped this month so I changed it to local, but I would substitute IQ Plugin for the data source.
image

It works on 5 minutes bar.
But it fails on daily bar.

Thank you.

When you say it works on 5min but fails on Daily, are you saying you are getting 5 min data before 2016 but when you try to switch to daily, it “chops” off the data to only show 2016 > 2017 dates?

Yes,galindog.
Data is back to 2007 when amibroker database setting of base time interval is 5minutes.
Data is only back to 2016 when amibroker database setting of base time interval is EOD(end of day).
I use iqfeed to get the data in amibroker.

ARe you changing the base time interval in the database settings from 5 m back to EOD?

I use two database.
One is for 5 minutes and the other is for daily bar.

it’s better you ask to IQFeed support chat, They are very professional and know well Amibroker

I have asked iqfeed.
IQfeed says their daily back to 1998(AAPL).
So I ask amibroker forum again.

'Thank you.

I am afraid I can’t offer any more help bec I only use 1 db with a 5 min
minimum interval.

My question is…why would you need to use 2? As long at you put your
base interval to the minimum you think you will need for future use
within AB, it does a great job in aggregating the 5’s into
10’s,hourlies,dailies…

@chengyensheng your problem is that you do NOT follow instructions.
You have entered absurd values like 192 years in Database Settings.

You should set up you your database AS INSTRUCTED in the video
http://www.amibroker.com/video/IQFeed.html
and in the manual:
http://www.amibroker.com/guide/h_iqfeed.html

Other configurations than specified in the video and manual are NOT supported

IQfeed is REAL TIME streaming data source, NOT EOD only. You need to configure it as "MIXED Intraday/EOD mode" as it is written in the manual with base interval 1-minute and then you will get BOTH intraday data and long EOD data in single database without need to keep two databases.

If you followed instructions from the beginning you would not cause problems.

If you want to use EOD-only it would work just fine if only you entered SANE values like 5000 EOD bars (19 years) instead of 192 years. If you did that you would get data from 1991 and even older.

image

1 Like

Thank you Tomasz.
It fix my problem.

Thank you so much.

Hi, Regarding IQ Feed and Minute Data:

I have setup IQ Feed directly as described, however I only get a few days of historic minute data.
I'm currently on the IQ Feed trial, but I don't believe that is the issue?
Daily data (when db is configured for 1 min data) only goes back a year (I have mixed intraday/eod mode) as described above, so I guess that is where daily data is coming from.

I have even tried the 'wait for backfill' for a few stocks, as described here, but it's not pulling any historic data'.

http://www.amibroker.com/guide/h_rtsource.html#WAITFORBACKFILL

What am I doing wrong, I'd like to see the full history of minute data. ??

Thanks very much,

You should post picture of your database settings. Readers do not see your screen.

Apparently you have not followed exactly because if you only get few days of 1-minute data then you seem to have set improper number of bars setting in order to get multiple years of 1-minute data.

You need to do the (correct) math. If you can't do correct math then that would not be problem as there is online data calculator, see here.

Now, if you need multi years of very short interval intra-day data (such as 1-tick, 1-sec, ..., 1- min) in addition you would have to read here (How to increase number of bars).

So if you want to get e.g. 10 years of (24h) 1-minute data you would have to set number of bars to 3800000. But be aware of data size and whether your hardware can handle it.

1 Like

@fxshrat is NOT rude. His reply is exactly to the point. What is rude is your reply to his generous help. You should send screenshot because often people don't notice important details and you should follow his advice. See How to ask a good question

3 Likes

image

As attached, I assume I should get more than 3 days of 1 minute data based on this.

It's obvious that readers can't see my screen. This wasn't posted because I've tried multiple numbers of bars with the same result.

Second link seems out of date, that option is not available in reg edit as far as I can tell.

Also seems unfair to judge and say I haven't set it up right before we work that out, but whatever.

Thanks for trying, might be an IQ Feed trial limitation.

Now your screenshot proves that you missed important detail and why
sending screenshots is extremely useful:

image

This figure applies to Intraday data only. Not "Mixed EOD/Intraday" mode. Mixed EOD/Intraday mode requires A LOT more bars because EOD bars take space too (by default 10+ years of EOD data - and they take the "preference").
Also after increasing "Number of bars" you would need to do "Force backfill" for every symbol. Or better, setup new database with at least 500K bars in "Number of bars"

And ALL links given by @fxshrat work and REGEDIT works too. Just take a couple more minutes to actually follow his earlier advice instead just throwing it out of the window.\

For example with this setting (900K bars):

image

I got intraday chart like this:

image

As can be seen there are INTRADAY data starting from mid-2014 (above), and EOD data starting from mid-2008 (below).

image

And the plugin status shows exactly 900K bars available:

image

1 Like

No, that's incorrect. It is not outdated. You have to read it carefully. As it is said in that 2nd link it's a Windows registry entry that you have to set there in registry. It is clearly mentioned that it has to be set by yourself (see the 7 steps there). Of course it is not there if you have not set it yet. Simply do not rush but please take your time to carefully read a post (that has taken time to write).

No one is judging. You simply did not post a picture. "All" it was asked for was to post picture. "Exactly" can mean different things for many people saying "I did/followed exactly".

Please read the first word

How is that judging considering your limited information (limited because it needed guessing by reader) before my response?


Now that one is funny (to me). If it is that obvious then why not taking the (small amount of) time to make reader see something in the dark. (BTW other people would consider that quote of yours being rude).

1 Like

Ok, so, it's great that we can talk robustly, make a few assumptions, but still actually take the time to help one another, that's a great thing - I will always help where I can. I do thank you both and apologize for anything I've missed.

Super sorry for missing the Reg Edit creation thing FX, I did miss that.

Everything else still seems to be right though?

So:

  • I did mention that I had tried many combinations / lengths of history in the db setup dialog box. I posted that one image because those params are exactly as per the instructions (and it keeps being repeated that one should follow instructions) here:
    https://www.amibroker.com/guide/h_iqfeed.html
    and also here
    https://www.amibroker.com/iqfeed.html

  • To prove I've tried a few things, here are a few more screenshots, note that I still only get a few days of minute data:
    IQ

  • So I'd assume that I wouldn't need the regedit change to at least get more than 3 days of data, but in any case, in addition to the above, I have just changed the regedit as described.

  • I went back to AB, opened database settings, put in new values, but I still don't get any more data.

  • I'm a little confused about the 'force backfill' comments. I only have two symbols in the db so far. They have been added just by creating a new chart. Further, I right-clicked and hit 'force backfill', is that not sufficient?
    db
    Thanks again

As per manual:
http://www.amibroker.com/guide/h_rtsource.html

Using plugin context menu

image

Force backfill - this option causes that plugin re-downloads entire (intraday) history from the server. Usually the plugin automatically handles all backfills so you don't need to trigger backfills by hand. If the plugin detects that you have some missing quotes from last available bar till current date/time it triggers backfills and it is all automatic. But... in at least two cases this option is useful:

  • backfilling more bars after settings change (when you enlarge 'number of bars to load' in File->Database Settings dialog you have to force backfill for symbols that were backfilled previously with smaller number of bars)
  • cleaning up bad ticks (when you see a bad tick you may try forcing backfill in hope that data vendor has cleaned up its database and you will get fixed data - works well for eSignal that really appears to fix bad ticks after they happen)

Once you click "Force backfill" you should see in the IQFeed plugin window that is actually displaying that bars are backfilled like this:

test

Now, if you cannot get it to work. Please create a NEW database, and follow this is entire sequence that is required to setup IQFeed intraday database with mixed mode:

test

1 Like