Is Amiquote 3.22 downloading Yahoo historical quotes these days?

Hello all,

I am experiencing some issues with Amiquote after attempting to get my database set back up again. I realize that Yahoo has been creating some issues over the past while, but I understood that these had been addressed in 3.22.

Rather than complicate things with Amibroker in the mix, I am only using Amiquote for my trial. I first identified the amiquote download folder by going into Tools > Settings. I then went to the file folder and deleted all the old symbol files in that folder. I then opened a tls file in amiquote and the amiquote window populated with all the symbols from my tls file. Perfect! I then selected 3 years between from and to dates and attempted to download historical quotes from Yahoo. The first line of the amiquote window populated with the error message:

“Yahoo error code not found description: Encountered an error when generating the download data”.

I terminated the download after 125 symbols. Aside from 8 out of the first 125 symbols that did somehow import correctly, the remainder of the symbols populated with the message “Yahoo error code unauthorized description invalid cookie”. A look at the Ahq files in download folder reveal those that imported had data and all the others were empty at 0kb.

Can anyone confirm whether Yahoo historical quotes are working in Amiquote at the present time? I had no access to my computer for the past 10 months and I know there have been some Yahoo changes, but thought that the issues had been resolved with the latest Amiquote release. I was having better luck a few days ago, so perhaps Yahoo is up to tricks again. I am running Amiquote 3.22, but on the bottom of the screen it still says there is a 3.22 version available. Any insight from others would be welcome. Anyone else having issues?


I confirm that AmiQuote is having issues with Yahoo data. As of this morning Australia time the error you described arrived with my setting “Yahoo Historical EOD etc”. Another local Trader alerted me to the error. He said that it was associated with the Aussie NBN because he accidentally found that it is OK using a different supplier than our NBN. I too have the NBN as internet supplier. So I tried to download using my phone HotSpot, and it worked OK.

I get the problem for both US stocks and Aussie stocks (.AX extension) and for Yahoo Indices (^XXX). So for my colleague and me it’s like this: NBN (most of Australia) fails.

Google historical data is patchy, maybe 80% good.

I waited until now, waited until a good time had passed, to see if the problem was fixed. OK so at 0745 New York time which is 2145 my time, I did extensive tests and all was well again.

{I was worried because our group of Aussie TfaC Traders club have a WorkGroup gathering for next Sunday to learn about AmiQuote with Yahoo to establish databases of US stocks in real time for trading US stocks. Fingers crossed from this until then.}