Jurik Tools & problem with current working directory

After installing Jurik Tools, I am having a problem. AB starts with an error "The formula file (null)referenced by this chart cannot be found.
Current working directory is "C:\windows\system32."

The "start in" property of the shortcut icon seems to be correct ("C:\Program Files\AmiBroker").
In preferences>AFL , The include path and formula tree path are relative to windows\system32. I change these to be relative to the amibroker folder. I save every thing and restart Amibroker and I am back to all of the problems described above.

Is there a secret location where the current working directory path is stored?
I will appreciate any advice I can get,


You might check Tomasz replies in these threads:

Maybe reinstalling AmiBroker will solve your issues? I quote Tomasz from one of the above threads:

Check Current working directory. It must be set properly in "Start in" field in the shortcut to the directory where AmIBroker is installed. It is set correctly after running setup.


Apparently Jurik on your machine changes working directory. Or you (or they) are starting AmiBroker from OLE (script). Contact them and look at the links @Milosz provided.


Thank You for your fast response. After posting on the forum, I did some tests and it does look like the culprit is the jurik installer. I sent Norman Smith of Jurik an email detailing the steps I took and the results. A copy of that email is included below.

What I am hoping for now is a work around until it is fixed, if that is possible.

Thank You,


///Email to Norman Smith, Jurik Research


I have done considerable searching and experimenting, trying to find a solution to my problem. My latest experiment seems to indicate that the problem may me the jurik installer. Here is what I did:

  1. I got rid of "Wise trader toolbox".

  2. I created a new directory for Amibroker and did a full installation. (AB ver 6.20.1).

    It started in the correct directory, "C:\Programfiles\Amibroker". (The "Start in" path of the Amibroker shortcut icon is how that is set.

  3. I created a new Database for IQfeed and added one symbol.
    Everything worked fine. I restarted Amibroker and it again started in the correct directory.

  4. I copied my formula directory into the new amibroker folder and selected the formula that I have been working with.
    All was good. Restarted Amibroker and all is good.

  5. shut down Amibroker and ran the jurik installer.
    Not so good. It starts in the working directory "C:\windows\system32". The Shortcut Icon has it starting in C:\Programfiles\Amibroker. No matter what I do it starts in the wrong working directory.

FYI: I open a formula(after navigating away from the system32 folder) in the AB editor, added a jurikjma and plotted it on a chart. Seems to be OK, But having it default to the wrong working directory every time is inconvenient in the extreme.

I have submitted a query to Amibroker about this, but I suspect you may have to work this out with them.



You should be starting AmiBroker from AmiBroker's own ICON, not from Jurik installer.


I actually did start from the Amibroker icon. It always has the correct path for "start in"(C:\Programfiles\AB Test 2), But when start up is complete it is always in C:\Windows\System32

What I mean is that the working directory in the error message on the chart when startup is complete is C:\Windows\System32. The "Start In" path in the Amibroker Shortcut Icon is always the correct path.

This means that the Jurik's plugin changes current working directory which is of course wrong. Remove Jurik plugin from Plugins folder until they fix it. Having said that, no-one else ever reported such problem with Jurik so it maybe some other 3rd party program/add-on/script on your machine.

You can also check what they have put into your C:\WIndows\system32. This directory is protected in recent versions of Windows and third party installers should NOT place anything inside it.

When all of this started, I did have "Wise Trader Toolbox" installed on my machine. It caused some minor problems ( asking for my license key during startup). I did my best to remove it, but what I don't know is if it left anything behind. That is one reason I created a new directory and did a full install of Amibroker. Everything was fine until I ran the Jurik Installer.

I'll let you know if I figure this thing out.


I have been contacted by Jurik Research and they have now acknowledged that the problem is with their software. They said a fix will be made in a week to 10 days.