Keyboard shortcuts conflict. Typing mystery into formula editor: "L" and "M" not showing

I have a strange issue for months now, and I am not sure at all this is due to Amibroker itself but here it is:
when I am creating or editing an AFL within the AFL editor, there are 2 characters I am unable to type: uppercase "L" and uppercase "M". Lowercase L and M will fortunately work.
I use the latest version of Amibroker, am on Windows 10, with an Azerty keyboard, and this issue appears nowhere else (typing in wordpad, word, text editor, and all other apps I have for that matter).
Have anyone had this issue already?
This is too minor for me to reinstall Amibroker, but that might be the solution though.

Did you try a reset all of keyboard customization ?
Tools->Customize->Keyboard Reset All

5 Likes

Man, you are damn smart !

I did what you proposed and it just worked – « M » and « L » are back !

Thank you,

Carl

It might be also worth noting, that in some specific cases keyboard shortcuts might be "intercepted". For example there are many Forum keyboard shortcuts. Shift + "r" in the AFL Editor gives you (as expected) uppercase "R" but if at the same time you are using AmiBroker Discourse Forum and the browser is in focus, you might accidentaly start replying to some post :wink: Here are our forum's shortcuts:

Forum%20Keyboard%20Shortcuts


Besides there are also many Windows shortcuts which might interfere with different programs' settings. I used to have a lot of problems, because I didn't know that pressing Alt + Shift or Ctrl + Shift changes Input language or Keyboard Layout in my system:

As soon as I deactivated these system shortcuts, my problems disappeared and I also could use my own Ctrl + Shift + ... combination shortcuts in AmiBroker :slight_smile:

3 Likes