No chart backfill with MT.dll

Using latest 6.20.1 Amibroker Professional verson. Trying to use Medved Trader through MT.dll plugin to feed data into Amibroker. I have the HTTP API enabled in Medved. I manually selected backfill in Medved to make sure the app had price history, but in Amibroker no quotes on the chart are filled. The connection is OK and green, the realtime window works properly and updates with prices for the selected symbol. But still receive the "Not enough data available" on the chart because no prices are input. I thought maybe just the backfill wasn't working and left it running for an hour to see if at least new bars would load, but nothing. Been racking my head for the past few hours trying to come up with the problem.

At minimum you would need to send a screenshot of File->Database Settings.

Here you go. Tried using EOD, intraday, and mixed EOD/intraday with no luck. Been happily using Amibroker for probably a decade and never had problems with previous datasources (esignal, IQfeed, Norgate historical, etc). So not sure what is going on here.

12%20PM

http://www.amibroker.com/devlog/2016/09/13/medved-trader-data-plugin/

and

http://www.amibroker.com/qtracker.html

Mixed mode is NOT supported by MT and needs to be turned off

I understand and it makes sense why EOD without mixed mode does get 1 bar. But the same thing happens for intraday set at 1 minute (without mixed mode) and then manually backfill though Medved. One bar is retrieved and no new bars are generated while leaving both applications open, so a chart can't be displayed. All the while, the realtime watch is showing price updates.

Base time interval in File->Database settings should be set ONCE, and should NOT be changed afterwards.
You need to understand that normally as described on the web page http://www.amibroker.com/qtracker.html the plugin would NOT re-request old data (older than already present in the database)

Use optimized routine for intraday data retrieval - turning this on (default, recommended) significantly speeds-up data retrieval in intraday modes. If this option is enabled and AmiBroker already has partial intraday data for today AmiBroker asks QT just for a few last time and sales records that occurred since last update upto current time, if this option is disabled AmiBroker always asks QT for time&sales records from entire day.

So if you are changing base time interval and want to get whole history you need to turn this option off.

When I delete this file it re-appears. I want it gone because I think it's causing instability. Why would it re-appear the way it does? thanks.

x

Randomly deleting any application file isn't recommended, you should have good reason for it.

default.layout is an app file and it will be created every time you run AB when the Layout settings will be saved to it.

If you think you are having problems with a Layout or if something may not have been saved correctly,
open AB and set a new Layout.
Then follow the steps here to set a new Local and Global Layout so that file will be updated.
https://www.amibroker.com/guide/h_sheets.html

Then click new layout "set as default"

Incorrect posting isn't allowed in Forum Rules, you should either choose a relevant existing thread or start a fresh one.

2 Likes

Thanks travick.

I just deleted MT. Got rid of it.

There are a few things here, all may not be relevant to AB itself.

default.layout in windows is assumed to be an application file extension that has been assigned to MT.

What you have is a file association problem, see how to change it


otherwise just righ-click > open with > choose notepad, and select checkbox "Always use this app"

1 Like

That will be handy, thanks.

1 Like