Norgate database stuck at launch

Hi @Tomasz

I've started having a new problem with Amibroker today. When loading the program, Amibroker runs through initialization - loading plugins, loading database, preparing user interface - and then gets stuck at "Opening charts".

I've waited and given it time but 5-10mins and it is still stuck there.

How do I fix this? Do I need to reinstall Amibroker?

Thanks for your help!

Check this post first: AmiBroker closes Itself - #3 by Tomasz

If that doesn't solve your problem, you will need to provide more details, like whether you have recently installed new plugins or databases, tried to move AmiBroker, etc.

1 Like

Thanks Matt - @mradtke

I will check that post. I also found this and am working through this:

Will try and come back if I need more help. I recently started using Norgate, seems like that may be the issue.

Problem solved. Thanks again to @mradtke for the quick reply.

Following the troubleshooting steps, I diagnosed it was something to do with my database. I recently began using Norgate Data. Before deleting files and reinstalling everything, I went into the Norgate Updater, clicked on databases and redownloaded all the databases. That seemed to do the trick as things are working again now.

It is NOT AmiBroker that is stuck.

It is Norgate plugin that got stuck while accessing data.

Remember: when you are using 3rd party data source the PLUGIN TAKES TOTAL CONTROL over data access. If it hangs/gets stuck then the entire program will appear "stuck" because AmiBroker is WAITING for plugin to return and it never returns.


This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.