Partially connected with eSignal data feed

I have subscribed to esignal with extended data history and configured it with amibroker as Given in instruction It worked for first time
now it shows " Wait Partially contacted "

image

"Partially connected" means that it is connected only to either local data manager OR remote historical backfill server, while it should be connected to both.
Check the password in File->Database Settings->Configure
and
check the firewall / antivirus if it allows AmIBroker to connect to internet without restriction.

I have checked everything . Even Data Feed is connected if i start esignal softwere it takes data Correctly and shows all servers are connected but when connected with amibroker it gives above issue

As I wrote you should check File- Database Settings - CONFIGURE

account password and user name

1 Like

It worked but
it is not getting extended intraday history .It plots only 1 yr of 1 min data
I Have subscribed to Extended Intraday history of esignal
image

Does the eSignal Extended History work with Amibroker or not? It would be nice to know whether it worth subscribing for it or it is just a waste of money. This is what I found on their site:
"The Extended History add-on was recently made available to third party applications. However, each individual 3p vendor will need to make some coding changes in order for this feature to work in their software. Please contact your third party vendor to confirm or request the availability of the extended history add-on. Please note, however, that the Desktop API and applications created with it do not support extended history."
https://kb.esignal.com/display/2/kb/article.aspx?aid=1203

It supports extended history and yes the plugin has special code for that feature. The requirements are:

  • you have to use 64-bit version (eSignal stopped supporting 32-bit long time ago)
  • you have to be subscribed to paid option "extended history" on your eSignal account.
  • the checkbox "Use Extended intraday request" must be turned ON (in File->Database Settings->Configure)
  • your database has to be configured with significantly large Number of bars (way beyond default 500K bars), see: How to increase max. number of bars (Database settings)
  • after you change the Number of Bars setting for existing database you have to do "Force backfill"
  • please do the math about how many bars you need as too much is bad too see http://www.amibroker.com/guide/x_performance.html