Pattern Explorer causing trouble, The parameter options are lost

Hello, can anyone help me so that the parameter options are not lost after turning off amibroker?
For example:

  1. I have an indicator and have parameter options according to many watchlists. Every time I turn it off and on again, this option selects the default watchlist.
  2. I use Pattern Explorer's chart, I change the candle color, change the EMA parameters,... every time I turn off amibroker, the chart returns to Pattern Explorer's default.
    I tried using 2 types of save: Save all, Save the database but it didn't work.
    Thanks

You need to run FULL INSTALL

as apparently you don't have write access to AmiBroker directory or you have virtualized access.

Make sure that you don't have VirtualStore folder like this:

C:\Users*current logged in user*\AppData\Local\VirtualStore\Program Files (x86)\AmiBroker

If such folder exists, it means that your AMiBroker was NOT properly installed in first place.
Existence of such folder means that writes are redirected by Windows to wrong place (VirtualStore)
and they may cause all kinds of troubles including inability to save new content.

To fix that you need to:

  1. Delete Virtual Store folder
    C:\Users*current logged in user*\AppData\Local\VirtualStore\Program Files (x86)\AmiBroker

  2. Run FULL SETUP of AmiBroker

Thank you, but it doesn't work when I installed Pattern Explorer.

VirtualStore folder doesn't have \Program Files (x86)\AmiBroker (checked)
When I reinstalled Ami as instructed, before installing PE, the Parameters worked fine and were not reset after closing Ami.

However, when PE is installed, the Parameters are reset, even with Ami's original afls.

Pattern Explorer is 3rd party creation and as such is not supported by us. You need to contact Pattern Explorer author for explanation why it is doing that.

Sadly, but many third party products are not upto AmiBroker standards.

Parameters are stored in broker.params file. Chances are that your 3rd party product deletes the file or otherwise modifies it in wrong way.

2 Likes

Yes, I contacted 3rd party and problem is solved. Thank you!

It would help the others that potentially might have same problem if you actually shared the solution or at least what the problem was.

Coming to the forum for help is good, sharing knowledge is better.

The problem is caused by a data source plugin. I changed it. :smiley:

But what data source plugin it was?