Possible to ignore composite symbols during exploration?

I happen to have a lot of composite symbols in my Amibroker database. When I do exploration, it takes quite a long time because the software is scanning through the irrelevant composite symbols. Is it possible to skip the composite symbols during exploration to speed up exploration?

The names of composite symbols start with ~.

You could create a watchlist that contains all the symbols that you DO want to process with your exploration, or you could exclude Group 253, which is the default Group used by AddToComposite(). These options are both available by setting Apply To to "Filter" and then clicking the green funnel icon.

2 Likes

If your are facing performance issues, you can check out
https://www.amibroker.com/guide/afl/staticvaradd.html

StaticVarAdd() is not a 100% functional replacement of ATC but if you are not using even 4 columns with unique data then you can consider switching or rewriting a bit of code.

Performance difference has been explained well in the Article.

I don't think this statement is entirely true. There must be something in your setup or code which appears to be doing something else in conjunction.
However, you can try using a watchlist as Matt suggested but I'm still doubtful

1 Like