Problem: RT Metastock plugin data provider force limited ticker file size


I am using metastock data plugin to connect my real time intraday data source with amibroker, but recently I had a problem of lagging the data , I talked to customer service and they told me to keep the size of tickers files small not exceed 500 Kb (Limited data). The problem is that I want to have the data for at least 2 years ( MS file size more than 2 Mb) at the same time I want to keep the real time data healthy and synchronized by keeping MS file size less than 500 Kb.

Currently I am thinking to import historical intraday data to amibroker database but I failed to get it work, AB only shows the provider limited historical data ( does not show the historical data in addition to provider most recent data). Also I tried to address the two data sources folders (Historical and realtime) into the metastock data plugin and all I got is to get the data of the last pathed folder.

In a nut shell, I want to save and view historical data in AB database in the same time I want to use MS data plugin to be able to view realtime data.

I appreciate any Idea or help to solve this situation.


This may be a one time process,
but you could Load the DB that has the historical data and export it to ASCII files.

Then import it to the DB that you use for RT data. You will have to provide specific info of your DB settings, and since you say that MS file size is limited, it wont overwrite the old data if you restrict the "Number of bars".
Local DB size from Preferences should however have sufficient space.

Dear @travick thank you for your fast response, I have already did what you have said (ASCII files) but after import nothing added.

I have a question about the role of the database folder in the amibroker bath if amibroker does only read the MS data specified in MS data plugin?

Thank you

You can't import data into database that is controlled by the plugin, read this

As written in the manual, data plugin has total control over the data and will overwrite any additions/edits anyway, so AmiBroker has read only access to external databases.

If you want to "add" one data set to another, you must use local database without plugin. You need first to import from Metastock (File->Import Metastock) and later import ASCII.
But obviously since such database is NOT connected to external database, it won't deliver "real time" updates.

So your best bet is to change data provider to one that is delivering data that you need.

1 Like

Thanks @Tomasz, I have realized that and solved the issue by deleting some old data from MS files although it provide less data than before but my data provider software does not show problems with its current file size, It seems that I have to repeat that every time the dataprovider software show such issue.