Problem with auto hide mode on Symbols window


I have a small problem but pretty annoying. I can't turn off auto hiding Symbols window in Amibroker. I tried to restart Amibroker and Computer but still the same problem. It's always in the auto hide mode and I can't turn it off. I don't know when it happend but it used to work fine. Other windows like Charts or Layouts works fine.

Just click on the "PIN" button



A week ago I started having the same problem as described above. I can't turn off auto hiding Symbols pane. Layers, Layouts, Charts etc. panes behave correctly - I can pin or unpin them, dock or undock. The problem occured when one day I started playing with different panes locations (Symbols, Layers, Layouts, Charts). A few minutes later I wanted to go back to the settings I used to have for years (Symbols pane always visible) - and I couldn't. I didn't install anything or changed other settings. I have never experienced a similar problem before. My system - WIN10 19.09 - AmiBroker 6.38 32 Bit.


Although Tomasz wrote in another thread:

I quote:

If you still experience problems, it works fine for everyone else, there is no "fix" that can be done in AmiBroker - since as you say it just works for ALL other tabs being handled by SAME code

... I think there must be a way I can return to my previous settings. I use Symbols pane with different watchlists a lot and this auto hiding is very problematic for me.


Try DOUBLE CLICKING on Symbols window caption bar

1 Like

Tomasz thank you for the tip - I have just tried it. A double click works for all other panes (Layers, Layouts, Charts etc) but not for Symbols.


Thanks @abhishektiwari

I have already reinstalled AB (upgrade mode from 6.38 to 6.38) and it didn't help.

I know this should help, but I would rather try other measures first, because I did a lot of customisation in my AmiBroker and I wouldn't like to start from scratch :wink:


Reinstalling does NOT fix anything, never, ever. Software does not work that way. Software is deterministic. It works THE SAME all the time, until YOU change something. The only reason is external factor - you have installed something that changed the way how things work - either plugin, or some OTHER program, or some Windows update or some mouse driver or antivirus corrupts your files on your machine, use 'registry cleaners' or 'Windows optimization' programs or anything else, but it is external factor.

Just move that window elsewhere. Hold down CTRL KEY, move it, undock it. Re-dock it as TAB, or

just delete the registry key (entire key with all content):



Tomasz, I don't use registry cleaners or any other AV software apart from Windows Defender. I tried reinstalling AB (after spending some time searching for the solution on my own) because as I know, if for some strange reason a part of AB setup is corrupted or missing, there is a chance that it might be fixed when the upgrade mode reinstalls and overwrites some files. At least that is the case when a user deletes some afl files which are part of a standard setup. So it was worth trying.

I wasn't able to dock or un-dock Symbols pane (even holding down CTRL KEY) but ...

This is turned out to be the solution! :slight_smile: As soon as I closed AB, deleted above registry key and reopened AB, all panes (including Symbols) started behaving as expected. Now I can pin, un-pin, dock and un-dock Symbols pane without any problems! What's important, all other settings (like custom toolbars, shortcuts, buttons, charts in the layout etc) were preserved and didn't change. So I recommend this solution to all users who might find themselves in a similar situation.

Thank you very much!


Yes, I gave you the key that only holds docking pane layouts so nothing else is affected and deleting it just resets docking panes to default.


Thank you !! Searching for this solution for years !!


This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.