R-Math plug-in compatibility

Is the R-Math plug-in (which is 32 bit software) compatible with 64 bit amibroker or does it require 32 bit Amibroker installation?

Thanks
Ara

Microsoft has the answers for you:
https://msdn.microsoft.com/pl-pl/library/windows/desktop/aa384249(v=vs.85).aspx

"32-bit processes cannot load 64-bit DLLs for execution, and 64-bit processes cannot load 32-bit DLLs for execution."

Is the R-Math source code available? Could it be compiled in 64-bit? For instance, R 3.5 is 64-bit.

Thanks,

P

No, R-Math plugin was written by one of our institutional clients and it is closed source. Plus it does not work with multithreading because of limitations of R itself (R is not reentrant).

It is recommended to use built-in matrix functionality in AmiBroker instead which is fully multithreaded.

1 Like