Remote Desktop: Empty rows and backfill issues

I am running 64bit Windows Server 2003 with AB 6.27.1 via RDP and I am subscribed to the Interactive Brokers data. I have applied IB plugin. How do I prevent backfill amount selection at the connection icon menu from being grayed out? Also what could be the cause of the strange data output via that IB plugin?

Another thing is that the symbols window is showing empty rows when scrolling and symbols appearing only when scrolled to the end. Could it be Windows theme causing that?

Another thing is that if I try to backfill an option symbol then a notify window will show up telling something would be wrong with IB plugin (but that message won’t show up when backfilling stock symbols).

  1. Please send screenshot. It should look like this:

  2. Remote Desktop is not the same as using Windows normally. Remote desktop uses various tricks NOT to transfer too much data if screen refreshes too fast. The result of such "bandwidth saving" by remote desktop is visible artifacts on screen during updates. You can google for remote desktop refresh issues

  3. Again you need to check RDP for messing up the display.

The application does not "know" that you are using remote destkop and does not behave "differently". It renders pixels normally on display surface then RDP takes those pixels and attempts to transfer it thru limited bandwidth chanel. Any display issues are due to RDP.

We have fixed the empty rows issue. It was a lot of empty symbols being entered by the user, so there is no windows display issue now.

The only issue being left is that the backfill selection is grayed out and remote desktop has been ruled out as a cause.

I think only AB can help on that one.

Is it possible to get support from AB?

Those items are NOT disabled by AmiBroker. Try using AmiBroker without RDP.

Based on feedback I get from people AmiBroker works with Parallels, VMWare, Virtual Box, Wine and similar virtual machines and virtualized environments. But such configs are not advertised as official platforms for AmiBroker so your mileage may vary. I physically can’t support that many platforms.

I have no idea. I don’t use

I wrote you: I have no idea. I don’t use that.

I am trying out a new VM to see if I can prevent the Amibroker Backfill Length options from being grayed out, and am running into trouble getting a new install of Amibroker to connect to Interactive Brokers again.

I have installed the controller in the Program Files/Amibroker directory instead of the 64 bit directory that it defaults to but when creating a new database named IB from with Amibroker, I still only see local as a choice and am unable to select Interactive Brokers.

Once I make it past that, I can see if it will work in this new VM.