Repeated Disappearance of Local Layouts in Database: Seeking Solutions

Good afternoon!

I'm writing to you because something very strange has happened to me twice in the last week.

The first time, I didn't think much of it. However, now that it has happened again, I'm a bit more concerned and wanted to know if anyone else has experienced this.

I have different local layouts created in my database, and they disappeared when I was working with my computer. AB crashed and when I opened again the layouts were broken.

Three days ago, I regenerated all of them, but today I find myself in the same situation. They have disappeared again. I have the .chart files saved, so I can easily recover them, but I would like to know if anyone else is in my situation or if anyone knows why this is happening to me.

If I try to backup the AWL file but it does not work. It only works with the .charts

As you can see it says that it can't find the current directory. The formulas are still where they where and if I right click and Edit Formula the message that appears is File path is null...

Thank you very much in advance.

Good afternoon!

I'm writing to you because something very strange has happened to me twice in the last week.

The first time, I didn't think much of it. However, now that it has happened again, I'm a bit more concerned and wanted to know if anyone else has experienced this.

I have different local layouts created in my database, and they disappeared when I was working with my computer. AB crashed and when I opened again the layouts were broken.

Three days ago, I regenerated all of them, but today I find myself in the same situation. They have disappeared again. I have the .chart files saved, so I can easily recover them, but I would like to know if anyone else is in my situation or if anyone knows why this is happening to me.

If I try to backup the AWL file but it does not work. It only works with the .charts

As you can see it says that it can't find the current directory. The formulas are still where they where and if I right click and Edit Formula the message that appears is File path is null...

I just realized that the default formulas have disappeared from the folders.

Does anyone have a clue as to what might have happened?

Most likely other software like antivirus corrupted broker.newcharts file.
Together with layout files you must restore broker.newcharts.

https://www.amibroker.com/guide/x_files.html

1 Like